The Unsupported Database is issued in the following situation:

Either change the Database or the Application Server properties of your extension. How?

See Also

Create an Extension | Update Extension Source Code | Resources Tree |Warning Messages