Can't see public actions create/update/delete in a mobile app

Can't see public actions create/update/delete in a mobile app

I'm building a mobile app, that uses data on another espace, i made the entities public and set the "expose read only" to no, but on the mobile app i can see the entities, but its only read only.

There is only Get() funtions, there is no create or update.

I need the mobile app to create records on the entities from de base espace.

What is missing ? any ideias ?

Hi Mário,

You may need to open the add/remove references window to refresh those entities.

Tiago Simões
Done that!! Several times.... It doesn't work.
i even tried a new mobile app from scratch, got the same result.

Any other ideias ?
Hi Mário,

Do the entities have an Identifier attribute? Some entity actions only appear if there is an identifier.
If they do, then it should be somehting else. To better understand your problem you could attach the two eSpaces (or simplified versions of them).

Tiago Simões
Hi Tiago,

I attached a osp with both apps (base and mobile).

The goal is to the mobile app view anda add records to most of the entities.

Mário Ferreira

Mario -

All of your entities are exposed as "Read Only", you need to set "Expose Read Only" as "False" to be able to call Create/Update/Delete from another eSpace.


Sorry, i uploaded the wrong file, i picked it up from the server instead off the virtual machine were I do the tests.
Here it is right file, were all entities have “expose read only” set to No, like my first post.
Thanks, Mário
Here is the mobile version, that still doesn't add records...
Mario -

This copy of the mobile app shows that it has access to the "Create", "CreateOrUpdate", "Update", and "Delete" methods of the entities.

What entities is not showing them? Are you sure you are not trying to look at the modify actions of a static entity?

Hi Justin,

You are right, now i'm also showing the "missing" methods, I must have messed up the refresh a couple days ago.

Thanks for your replies, and i am sorry for the trouble.