Lifetime 7.0.1.7 - Status offline

Lifetime 7.0.1.7 - Status offline

  
3 Servers, are added to LifeTime; the first time the servers sync with LifeTime, everything works just fine - all servers online.

A few days later, LifeTime indicates 2 servers are now offline
"Environment seems to be offline because it is not reachable from LifeTime."

"ServerCenter" error log shows
Invalid Login, Unknown user or incorrect password.

Reboot, same issue. Unregister server, re-register server server LifeTime syncs again, everything works fine! now a few days later, same issue LifeTime can not login to the servers added to Lifetime.

Anyone else experience this issue? 
Hi Robert,

LifeTime shows the message "Environment seems to be offline because it is not reachable from LifeTime." whenever it has problems to communicate to one of the managed Environments.
This happens usually when the target machine is having problems (e.g. full disk) not accessible from LifeTime (e.g. behind a firewall) or when there are network problems (e.g. DNS).

Your scenario seems different because it has been solved by the re-register of the Environment and we will have to investigate it further. The Service Center logs may be a good approach to the problem, but we need more details.

I suggest that you try to contact outsystems' product support if this is critical for you.

In the meanwhile we can try to help you, but we need more information: 

- Are those messages (
Invalid Login) from the LifeTime machine or from one of your offiline servers?
- When you're logged into LifeTime, is the error log from any of the offline servers growing? Can you provide us the list of the errors?
- Can you access the offline servers from the LifeTime machine?

Regards,
Hélio

Helio

"- Are those messages (Invalid Login) from the LifeTime machine or from one of your offiline servers?
>> From offline servers
- When you're logged into LifeTime, is the error log from any of the offline servers growing? Can you provide us the list of the errors?
>> When clicking on link message is displayed 
"Environment Health Problems  View more details", ServiceCenter is loaded, select "Errors" from ServiceCenter there is an incrementing log of errors (with message over and over, its Invalid Login)
 

- Can you access the offline servers from the LifeTime machine?"
>> Yes, able to access when clicking on offline server. (very strange)
Hello again Robert,

I'll take a look at it as soon as I get to work tomorrow and I'll get back to you if I need more info.

Again, if this is critical for you, I suggest that you contact outsystems' product support.

Regards
Hi Robert,

Let me give you a little more context how LifeTime comunicate with their environments before asking you for more info.

To comunicate with the environments, LifeTime uses a special user. This user is created in each environment when you register those environments in LifeTime.

Looking at the sympthoms that you described (invalid login in error logs and problems disappeared by unregister + register the environments), it sounds like something is going wrong with that user in your environments.

To better help you with this problem I suggest you to contact outsystems' product support.

Regards