Permissions problems in extensions

Permissions problems in extensions

  
I'm working on version 7.0 in windows server 2008 and sql server 2008.
I have one espace that runs in default IIS account (IIS_IUSRS) and in one of his extensions is using shell commands (System.Diagnostics.Process). Everything works fine in development but when I deploy to production I start having errors of permissions to Windows Shell to this user IIS APPPOOL\OutSystemsApplications. There is anything different in development regarding this and that may be causing the different behavior in both environments?
Hi Marcelo,

Are you using an impersonated user to run your application? Also can you share the detailed error message?

Kind regards,
Ivo Gonçalves
Hi Marcelo,

If you're using a impersonated user you can always use the "Run As" option in the Service Center (in the eSpaces that are using that extension)..

Kind Regards,
Gonçalo M.
I'm not using a impersonated user.

The error is event viewer is this :

"The machine-default permission settings do not grant Local Activation permission for the COM Server application with CLSID 
{682159D9-C321-47CA-B3F1-30E36B2EC8B9}
 and APPID 
{CDCBCFCA-3CDC-436F-A4E2-0E02075250C2}
 to the user IIS APPPOOL\OutSystemsApplications SID (S-1-5-82-2596511505-2023350010-2685897361-2300954378-2116148981) from address LocalHost (Using LRPC). This security permission can be modified using the Component Services administrative tool."
Hi Marcelo,

Check the following forum post:
https://www.outsystems.com/forums/discussion/3576/how-to-restore-lost-permissions-for-the-iis-built-in-network-service-account/

Follow the instructions described on it and let us know if solves your issue.

Kind regards,
Ivo Gonçalves
I tried to change the security of ShellWindows but i can't everything is disable.
Hi Marcelo,

To enable these options do as following:
  • Run regedit as admin;
  • Navigate to HKEY_LOCAL_MACHINE\SOFTWARE\Classes\AppID\{CDCBCFCA-3CDC-436F-A4E2-0E02075250C2} and right click over this key;
  • Select "Permissions" and give the proper permissions to your user;
  • Try again and check if the options are enable.

Kind regards,
Ivo Gonçalves