Link within webblock wont work

Link within webblock wont work

  
i have a webblock with an if, that either displays a text or a link,
which calls another screen passing 1 variable.
this webblock is used in other webblocks and screens.

situation: when the webblock loads, the link gets displayed nicely, no problem here
but when i try clicking the link, nothing happenes...

does any body have an idea, why the link is not responding?
i have tried navigate and submit, both didnt react on clicks.
the only way i could get the link to open, is by right-clicking and open-in-new-tab

do i have to link through an ajax screen action which will call the destination screen?
hope not... regarding the difference in SU's =)

thanks guys!
Hi,
Try to check in the HTML code of the link, what is the value assign to it in runtime.
When you do a refresh you can loose the value associated to the link.
You can try to see if this is the case using a temporary local variable to store the value every time it changes and then use for example a hidden button were you're going to click (using javascript or WidgetClick), going to the wanted destination screen and with the wanted identifier value.
It's not the most elegant solution (no at all..) but is a test you can use to find the cause of the problem.
Hope it helps.

Kind regards,
Gonçalo M.

hi goncalo, thank you for the hint

the link itsself looks as it should in the HTML
but what i noticed, was a onclick on a container, which was arround the webblock with the link.

as it seems, this container with the onclick action, somehow prevents the link from working.
once i removed the onclick action, everything worked nicely.
Nice to know that you could solve the problem (I didn't knew that you had a container on it).
I gave that tip because I already saw a behaviour similar to that..
I have a same problem but i can't solve it.

I have a icone inside a weblock that i wan't to link to download
The text is working with a link but i can't make the same with the image inside the weblock.

Thank for the help.