Database error in upgrade to OS 8

Database error in upgrade to OS 8

  
I installed platform server 8 successfully, but when I click in create/upgrade database in configruration tools 8 i have this error: "Database error: Database error- Incorrect syntax near '-'"



can help?
Hello Unknown Person :)

Have you installed the Community Edition or is this an Enterprise installation? If the later, is it on SQL Server or Oracle?

Eitherway, check if you have an hifen ('-') on the server or database name.

Cheers

Miguel Simões João
Hello,

I have upgraded the Community Edition with SQL Server.

only find a hifen ('-') I in server name "WIN-REFERENCE", in tables and database name not have.

I have done the upgrade from 6 to 7 a some time ago and had no problem.
 
Cheers
Pedro Coelho


Hello, 

In order to fix this problem you can perform the following steps:

1) go to C:\Program Files\OutSystems\Platform Server\db
2) open runtimemodel_sqlserver.sql
3) backup the file
4) search for and delete the following two lines:
 
 -- %SPECIFIC_UPGRADE% = "SpecificUpgrades.UpdatePreviousLogViews"
GO
 
5) retry upgrade

Let us know if this fixes the problem.

Best regards,
Ricardo Silva
Hi Ricardo,

thanks for the solution, upgrade complete :)

Best regards,
Pedro Coelho
Hi,

We just released the new version (8.0.0.4) of the Community Edition that solves this problem.
Get it here (http://www.outsystems.com/Community/download/)!

Happy coding!

Mário Pires