FileNotFound bootstrapping Excel data to JBoss / Oracle

FileNotFound bootstrapping Excel data to JBoss / Oracle

Hi there,

I followed the checklist for installation of the platform using JBoss 5.1 and Oracle 11. The checklist is really good, and a lot of the functionality seems to be working: can connect to the server, deploy a simple app. After the checklist, however, I found no further configuration-guide, what needs to be done on the Windows / Service Studio side? I installed an Oracle-client and used this to change DB-settings in the Configuration Tool (guess this is necessary to test queries in Studio?); anything else to do?

Then opened the PurchaseManagement tutorial app from my local server and reopened this on the new linux server, installed it: everything fine. So I reattached the "Actions to Bootstrap Data from Excel" and now on redeployment I get the error at the end of this post, files don't get transferred to the server, the directory is empty. What should be done?

Thanks for helping

Invalid compiler output. /opt/outsystems/platform/share/PurchaseManagement/full/.\/copyToApp/bin2/hidden_resources/Product.xlsx (No such file or directory)
Hi Theodoor. Can you check in the properties of the resource, in deploy action, if the "Deploy to target directory" option is selected?
Hello Pedro,
after opening the local application on the other (linux) server, all deploy actions are set to "do nothing". I think I tried changing this last Friday. Anyways, I did this again now and also reattached the files through "change resource", so that I am pretty sure that the local file paths are still correct. But to no avail, the directory on the server stays empty and deployment is stopped there.

Thanks for your support,
Hello Theodoor,

What version of the OutSystems Platform are you using? 8?

I just tried publishing an eSpace on version 8 using JBOSS with an eSpace resource and it worked fine.

Can you try to delete the share folder for your eSpace and try publishing it again?

rm -rf /opt/outsystems/platform/share/PurchaseManagement

Let us know how it goes.
Hello Ricardo,
I updated to locally earlier this week, there does not seem to be a newer version for Linux though.
Anyway, I deleted the directory, same error. Removed the complete eSpace over eSpace-Management, same error. Then deleted the resources and all actions associated, now I get a different error:
Internal Error
Could not create persistence information file '/opt/outsystems/platform/share/PurchaseManagement/full/.\/jsp/Theme.PurchaseManagement.css.cache' No such file or directory

Something is deeply wrong here, my last try will be a complete removal and a fresh install. Are there instructions on cleaning up the installation somewhere?

Is this happening to other eSpaces of yours? 

Can you share the eSpace file (oml) so we can check if it's a problem with the file?

If you don't know already, you can save the eSpace locally by going to eSpace > Export > Save as .

Hi Ricardo,
please find the oml file attached, it's one of the tutorial applications, quite exactly. I'm in the process of setting up a new Oracle Linux image, and discarded the old one, so I'm currently not able to test different eSpaces. But tomorrow I'll get to it.
Hi again,
just set up a completely new image, this time used Oracle instead of CentOS. Opened the exact same oml file I attached here yesterday, changed the resource actions to "deploy to target directory" and hit the green button: deploys like a charm.
A little worrying though, since it seems impossible (for me that is) to find out what is causing such a deployment error. The first installation also seemed to work at first glance.