Error sending log: System.Data.SqlClient.SqlException: "FASTFIRSTROW" is not a recogn

Error sending log: System.Data.SqlClient.SqlException: "FASTFIRSTROW" is not a recogn

  
I'm having this error in v8 and not appear the logs in service center:

Error sending log: System.Data.SqlClient.SqlException: "FASTFIRSTROW" is not a recognized table hints option. If it is intended as a parameter to a table-valued function or to the CHANGETABLE function, ensure that your database compatibility mode is set to 90.
"FASTFIRSTROW" is not a recognized table hints option. If it is intended as a parameter to a table-valued function or to the CHANGETABLE function, ensure that your database compatibility mode is set to 90.
"FASTFIRSTROW" is not a recognized table hints option. If it is intended as a parameter to a table-valued function or to the CHANGETABLE function, ensure that your database compatibility mode is set to 90.
"FASTFIRSTROW" is not a recognized table hints option. If it is intended as a parameter to a table-valued function or to the CHANGETABLE function, ensure that your database compatibility mode is set to 90.
"FASTFIRSTROW" is not a recognized table hints option. If it is intended as a parameter to a table-valued function or to the CHANGETABLE function, ensure that your database compatibility mode is set to 90.
"FASTFIRSTROW" is not a recognized table hints option. If it is intended as a parameter to a table-valued function or to the CHANGETABLE function, ensure that your database compatibility mode is set to 90.
"FASTFIRSTROW" is not a recognized table hints option. If it is intended as a parameter to a table-valued function or to the CHANGETABLE function, ensure that your database compatibility mode is set to 90.
"FASTFIRSTROW" is not a recognized table hints option. If it is intended as a parameter to a table-valued function or to the CHANGETABLE function, ensure that your database compatibility mode is set to 90.
"FASTFIRSTROW" is not a recognized table hints option. If it is intended as a parameter to a table-valued function or to the CHANGETABLE function, ensure that your database compatibility mode is set to 90.
"FASTFIRSTROW" is not a recognized table hints option. If it is intended as a parameter to a table-valued function or to the CHANGETABLE function, ensure that your database compatibility mode is set to 90.
   at OutSystems.HubEdition.RuntimePlatform.DBHelper.#Wab(DbException e, IDbTransaction trans)
   at OutSystems.HubEdition.RuntimePlatform.DBHelper.ExecuteNonQueryDontCleanParameters(IDbCommand cmd, String description, Boolean isApplication, Boolean skipLog)
   at OutSystems.HubEdition.RuntimePlatform.DBRuntimePlatform.CreateWebServiceLog(IDbConnection conn, WebServiceLog log, Int32 cycleSize)
   at OutSystems.HubEdition.RuntimePlatform.Log.LoggerSynchronous.Log(WebServiceLog log)
   at OutSystems.HubEdition.RuntimePlatform.Log.RuntimeLogger.Log(WebServiceLog log)
 
Message generated by eSpace ServiceCenter.


i check the database compatibility mode and is set to "Sql Server 2005(90)"
can help?

Community Edition Version 8.0.0.5

Thanks,
Pedro Coelho
Hi Pedro,

What SQL Server version do you have? (real version, not the compatibility mode)
Note that the platform does not require any specific compatibility mode to be set, so it should always be as higher as possible. That message is directly from the database and can be a bit missleading.

If the answer is 2008 or 2012, please run this query and post the result.
SELECT SERVERPROPERTY('productversion')

Edit: Also, did you do any Sql Server upgrade recently?

Regards,
João Rosado
Hi,

I have sql server 2012 and the query result is 11.0.2100.60

Pedro Coelho
Hi,

Thats stange because the platform doesn't use FASTFIRSTROW on sql 2012. Did you do something like a live sql upgrade from sql 2005 to 2012 without restarting the server?

Try to do a IISReset.
If that doesn't fix it, republish Service Center from the comfiguration tool (Apply button -> the say yes when it asks to install Service Center).

Also like I said on my previous post, compatibility modes are not needed by the platform. So unless you have some some other reason to have it like that, you should change it to 2012, followed by a sql server restart and an IISReset.

Regards,
João Rosado
Hi,

I have done upgrade from 2005 to 2008 and then to 2012, and always restart the server.

I change compatibility to 2012, IISReset, restart server, republish Service Center, and nothing result.

I have a long time the sql server 2012, this error started after upgrade to v8.
 

Hi Pedro,

We identified the problem, still working on a fix/workaround. I'll keep you informed.

Thanks for your fast replies.

Regards,
João Rosado
Hi,

Already got a fix for it and will be included on a future 7.0 and 8.0 release.
Pedro, in the meanwhile I'll send you an email tomorrow morning with a sql script to fix your database.

If anyone else also hits this problem and requires a fix, please contact OutSystems Support.

Regards,
João Rosado
Thanks João Rosado