Uploading ZIP > Page not found?

  
when i try uploading a zip file i get a 404 page not found error
but when i try a different format ie. png, jpg etc it works

how come zip wont work? are filetype privileges or similar needed?

thank you!
Hi Enigma,

can you explain a little bit more your use case?

If you could provide a sample it would be great!
hi pedro

unfortunatelly i cant upload the zip publically
it basically contains csv, pdf, jpg and gif files
zip file size is 54mb

the upload itsself is simple and straight forward
- upload widget (tried the standard one and also fileupload from the forge)
- and a button to trigger the action to process the file

when uploading a zip, after pressing the button, i endup on the 404 page directly
ie. the debugger will not break on a break point within the action
when uploading other files, the break point is triggered flawlessly

the platform server version is 8.0.0.3
Hello Enigma.

Check the attached OML. It has a simple page with an upload widget and an action that checks for the size of the file. The size of the uploaded file is showed in a feedback message.

I've tested it with a zip and other file types and it worked. My platform version is 8.0.0.3 also. Can you publish it in your envirnment and test it?

Cheers,
Pedro
hi pedro

i published your oml and tested it, unfortunately it behaves exactly the same
zip produces a 404 error and with other files the message shows the filesize
And if you upload a smaller zip file?

Maybe you're hitting a max file upload...
you seem to be right, if i upload a zip with only 1 image in it, it seems to work

but where do i increase the max allowed filesize?
regarding 54mb isnt really big, even mails can generally be sent with 100mb
You can find details on how to set that to recomended values in the checklist at http://www.outsystems.com/goto/checklist-8-NET
thank you very much pedro

just to be sure, that would be at "Microsoft Internet Information Services 7" > applicationHost.config > 5. maxAllowedContentLength ?
We usually do it by changing the xml files that are described in the checklist, but I guess it's the same thing.

I don't have a machine with IIS to check it right now... maybe someone can confirm that... guys?
Hi Enigma,
?
I believe the settings you should change are maxRequestLength and maxAllowedContentLength.
?
Cheers,
Tiago Simões
thank you guys, that did the trick

is there a recomended method to handle files that are too big?
regarding it can be quite confusing for the user, if he only gets a 404 error
Hi,

You can use the action "BinaryDataSize", I believe its part of the platform from 6.0 and up.

Cheers,
Hermínio Mira