ORA-00972 identifier is too long

ORA-00972 identifier is too long

  

I has a table called "conhecimento_fatura_transp" and a column "cd_conhecimento_fatura_transp". This table is used for desktop system and not has problem.
But in "Outsystem" when I use the "Create Entity" return the error "ORA-00972 identifier is too long".
This problem persist with other columns with big names but the name of column has 29 positions (accept by Oracle).
Don't has problems with values. I test with little values and error return too.
Hello Luiz

Are you using a database connection to import the table as an entity using Integration Studio? If so, can you let us now the version (revision) of the Platform you're using? I ask this because we've recently discovered a similar issue, and would like to check if it's related or not.

Thanks

Cheers

Miguel Simões João


Hello Miguel.
I'm not using Integration Studio, I'm creating tables in Service Studio. I would like to know if this is possible to do on Service Studio?
Hi Allan

Thanks for the information. If the tables are created in Service Studio, this means that they are Service Studio entities, and these entities are automatically managed by the Platform. Meaning that the table names on the database are automatically truncated to the supported length limits.

If you have a database table named 'conhecimento_fatura_transp' and/or 'cd_conhecimento_fatura_transp', then these tables aren't Service Studio entities, thus do have their name truncated to the supported lengths.

If you create an entity on Service Studio, and get this error creting a record on it, please provide us the espace where the entity definition and the create entity resides, so we can trace other possible causes.

Thanks

Cheers

Miguel Simões João

Hi Miguel

Sorry for the delay!

I use de Integration Studio 7.0.0.14 for access a entities. I has clients with SQL Server or Oracle and system with desktop. I use Outsystem from webpages in this system. I don't create table with Service Studio.

I can make AdvancedQuery with use of this table, but not can "CreateorUpdate"

Thanks for help

Hello Luiz

Thanks for the info.

Yeah, that behavior is consistent with the known problem which has been already resolved in Platform Server 7.0.1.13.

You're using Integration Studio 7.0.0.14, but which version of the Platform Server are you using? If you're using a Platform Server version lower then 7.0.1.13, then I would recommend to update to the latest 7.0.1 version to overcome this problem.

Cheers

Miguel Simões João