[Table Record Controller] Works with

[Table Record Controller] Works with

Forge Component
Published on 2014-09-24 by Hugo Pinheiro
23 votes
Published on 2014-09-24 by Hugo Pinheiro
does this component work with

i couldnt get the demo to work, yet im not sure if its the component or just me doing something wrong

PS: or is there a different method to dynamically arrange and hide columns? (or even build the entire table during preparation)
PPS: i found http://www.outsystems.com/forums/discussion/5965/table-records-with-dynamic-columns/
which basically suggests creating dummy date fields and hide them accordingly

i could work with hiding, but i would still require to rearrange the columns (same also needed in the edit widget later on)
since in my case every column is a different key identifier and they could be combined in any desireable order (keyA+keyB+keyC or keyB+keyA or keyD+keyB+keyC etc)

plus the columns have a priority (ie. check col1,2,3 first, then check 1,2 then only 1 and finally all)
so if the columns would be in the wrong order, it would confuse the user

Probably the upgrade to the 8.0 broke something, I will take a look and see what is not working.

Hugo Pinheiro
It should work fine now. I did the upgrade to 8.0 and I fixed the bug that was preventing from rearrange columns.
Best Regards,
Hugo Pinheiro
thank you very much hugo

the demo now seems to work nicely
only my own table doesnt seem to be working right:
when i try clicking rearange or edit/add preferences, only a "#" gets added to the url, nothing else happens

do the column names have to be exactly "Column_1", "Column_2" etc..?
or can they also be named "FirstThing", "SecondThing" etc?
Hello enigma,
There was a bug that I fixed on the OnTriggerPopup action inside TableController WebBlock. Instead of WidgetClick, I am using RunJavascript. 
But you should try just to reference the web block to be like a widget.
Best Regards,
Hugo Pinheiro
thank you, ive referenced the 3 webblocks TableController_Init, Slide and Widget
and set the extId, extName properties to all table columns
plus extOptional=true to all except one, and extFreeze=true to that one exception
(basically 1 column that must always be visible and the rest is optional)

but still nothing happens when i click rearrange columns

does it matter if the value of extId and extName are equal? ie. "RowActions"
and/or is the filter webblock of any importance?
Hello Enigma,

It shouldn't be a problem having extid = extname.

Do you have Javascript errors?

Can you send me your eSpace so I can take a look to better understand the problem?

Best Regards,
Hugo Pinheiro
Hi Hugo,

I have the same problem, when i click rearrange columns nothing happens.
I've done all the steps that are in the instructions.

So, if you can have a look, i send you me e-space.

Thank you very much,

Hello Joel,

I found the problem in your version, with the 8.0 platform there is two jQuery versions available that can be selected on the eSpace settings. Since I did this component in a previous version (7.0), you need to have selected 1.4.2 OS instead of 1.8.3.

Best Regards,
Hugo Pinheiro
Hi Hugo,

I have some screens that uses jquery 1.8.X. Can I use both?
Hello Vitor,

Yes you can use both, by having both libraries at the same time.
But in my opinion that the most robust solution is to adapt the widget to only use 1.8.X.

Best Regards,
Hugo Pinheiro
sorry for the late reply

how can i use 1.4.2 for the table controller and 1.8.x for the consuming espace?
since it only seems to work when both espaces are 1.4.2 (and i need 1.8.x in the consumer espace, for some other stuff)

thank you!
PS: is there a maximum number of columns supported?
or does there already have to be data in the tablerecords?

ive tried rebuilding the demo in a blank module - which worked
now i tried doing exactly the same in the actual module, where i need it - and it doesnt work

only differences i can find are more columns (9, later going to be up to 20)
layout_normal is different and theres 1 column which isnt in the entity/query and has no label (except for the extId/extName properties)
the problem is that this module is way too big to upload for public ^^
It has to be data on the table. I had the same problem here.
does it have to be effective data, or should an append blank record be enough?
i tried appending some blank records, but still doesnt work
i didn't try with blank values. Probably it has to be non-blank values.
it doesnt seem to work with data either
tried it with both JQ versions
Are you getting javascript errors? If possible can you share your solution with us, so we can help you.