Microsoft Reporting Services 2008 R2 Authentication

Microsoft Reporting Services 2008 R2 Authentication

  
Hi all,

I installed the report server with the platform version 7.0 in a client.
The reports run just fine, except for the anoyance of Internet Explorer always asking for username/password authentication when I want to run a report through our espace.

I though that, by configuring in the operation tab of the espace, a user to "run as", that user would be used automatically, but no. IE is always asking for the credencials.

What do I need to do for the browser to always use the credentials I supllied in the "run as", without asking?

regards
Hi Gonçalo,

The report page is owned by Microsoft Reporting Services that has its own security model. You should check what that is there. The "Run As" identifies the user running the worker process that executes your application on the server side, so this as impact for file system access for instance. In your case for what I understand you're showing the report on the client browser so the security context is the one from the client and not the server.
This link can probably help you out: http://technet.microsoft.com/en-us/library/aa337491(v=sql.105).aspx

Edit:
By the way check out this post that has a tutorial on how to configure reporting services 2000 (I think) that shouldn't be that different from 2008.

Cheers
I had a MSRS installation that I maintained for 4 years working with Microsoft CRM. I was NEVER able to fix this issue with that, and I spent dozens of hours of my life trying. :(

J.Ja
Hi guys,

For now, the only way I can stop IE from asking the credentials is:

- going to IE security options and choosing (under the user authenticantion) the "automatic login with current username and password";
- and on the report site configuring the data sources to run with "stored credentials on the report server" and there using an admin user;

But this is not a great option since I have to change every IE on the customer.
Thanks anyway for your input. =)
Do you access the report using a Report Server page? We developed an interface which just uses the RS webservices and returns the binary of the report back to you action in OutSystems, so you can decide what to do with it there. Show, download, email.....

Without all the security problems. Of course you have to provide credentials on the ws-call.
Hi Paul,

That sounds like a good idea. I'll try that and report back on the result.
Thanks.
Paul van Hoof wrote:
Do you access the report using a Report Server page? We developed an interface which just uses the RS webservices and returns the binary of the report back to you action in OutSystems, so you can decide what to do with it there. Show, download, email.....

Without all the security problems. Of course you have to provide credentials on the ws-call.
 
 Hi Paul,

Do you have the extension you developed for the interface?
Can you attach it here?

thanks
Gonçalo Almeida wrote:
Paul van Hoof wrote:
Do you access the report using a Report Server page? We developed an interface which just uses the RS webservices and returns the binary of the report back to you action in OutSystems, so you can decide what to do with it there. Show, download, email.....

Without all the security problems. Of course you have to provide credentials on the ws-call.
 
 Hi Paul,

Do you have the extension you developed for the interface?
Can you attach it here?

thanks
 Never mind. I got it to work ;)