Service Studio 8 not responding

Service Studio 8 not responding

When Service Studio 8 (currently reaches more than 1 GB in memory, starts hanging a lot and not responding.

I don't thing that its machine issue because I've 8 GB of ram and in those scenarios the Physical Memory usage is arround 60%.

I normally work, with the rest of the team, with a espace that was 10 MB, and after some hours of work and several merges its not difficult to have the 1 GB memory usage in Service Studio.

Is there any configuration or change than can be done to solve this issue?

I'm using Windows 7.


Hi Carlos,
It also happens to me, a lot, but running on windows XP, after lock the computer screen, when I get back and unlock of the computer, the Service Studio it's not responding.
Yesterday, an colleague of mine explained me a trick that it's helping me, for now the issue it's solved, but it's too soon to have sure that it's definitly solved.

Try to reduce the Hardware Acceleration on the Display Properties Settings:

Hope it helps you.

Kind regards,

Daniel Martins.

Hi Daniel,

thanks for the reply.

I've tried reducing the Hardware Acceleration I got a different error in service studio:

"Failed to allocate a managed memory buffer of 16777216 bytes, The amount of available memory may be low."

At the moment I'd at least 3gb available.

Carlos Freitas

did you guys figure out a solution for this? My Service Studio hangs and does not respond on my windows 7.
The problem almost always comes (for me) when I use "Refresh References" a lot, especially if I use the "Refresh Consumers" item from the "eSpace" menu instead of doing an "Add/Remove References" from the consumer. I know that they have fixed some memory leaks around this in (which did make things much better for me), and I suspect there may be a few more.

For me, I close Service Studio around lunch time and re-open it, and that keeps my day bug;hang/crash free.

FYI.  I'm getting simliar issue with release.  Still hasn't been fixed.
This is with 3 modules open in service studio.  This is getting very time consuming.

Hi Rebecca,

How big do you feel those modules are, regarding the number of objects (eg: screens, actions, ...) they have?
Also is there any particular pattern in your current workflow that you see as increasing the frequency of the problem?

Best regards,
Software Units
App 1:91899
App 2:15701
App 3:46101

Also, we have many espaces at our location but I can never use "Download Consumers" to work on updating references.  It always crashes service studio because there are so many of them.  So I have to make a list and open them one by one.
Hi Rebecca,

Are those SU sizes of individual modules or of applications that comprise several modules?
If they are made of several modules can you tell me approximately the size of the modules you usually keep open?
These are individual modules.
Rebecca, what Windows version are you on, and is it 32 or 64 bits? I'm on a 64 bit Windows 7 with 24GB of RAM, and the latest versions of Service Studio are pretty stable for me (with the exception of an occasional one in between). We also use large eSpaces with lots of consumers and producers.

wow, I'm still stuck with 4Gb...

Yeah, I hate swap files, and memory is cheap :)
I'm running 64-bit with 8GB of RAM.
Well, that should pose no problem. Even with 8GB (and a swap file) SS ran fine for me, and it runs fine with 6GB on the other developers' machines (I asked them if they needed a memory increase, and they didn't). So it must be something to do with the constitution of the specific eSpaces.