'Stubborn' Outdated Reference

'Stubborn' Outdated Reference

  
Hi guys.
Just wondering if any of you has some clue as to why there is a reference that is always flagged as Outdated.

If I open the References window, update it, press Ok and then open References again, it will show as Outdated.
I suspect this is preventing me from debugging that WebBlock from the producer eSpace, on the consumer eSpace.

This happened to me before on another project, but other than debugging, it doesn't seem to raise any other problems.



If I click on the webBlock itself, it says "Block preview was changed". This doesn't make much sense, because the preview is an Image on the "True Section" of an IF=False.

Anyone had this before? :)

Best regards
After trying to re-develop the WebBlock, step by step until the issue occurs again, I believe I  narrowed it down to:

This happens when the exposed WebBlock has inside it a second WebBlock, with a placeholder, and inside that placeholder a ListRecords with a third WebBlock with nothing special in it.

I refactored the exposed WebBlock without using the reusable blocks (the one with the place holder) and the issue got solved.

Conclusion: There seems to be a bug with placeholders.

Maybe it's a bug to look into. :)

Best regards.
Antonio -

Yes, you have found the right issue. I found this problem a few months ago too, and confirmed it with support. :)

J.Ja

Hi, 

I also have been experiencing this problem! And 'Stubborn' is the right adjective :D

Kind Regards,

Daniel Martins