Datepicker 'empty' on iPad

Datepicker 'empty' on iPad

  
I have a web application that when run on an iPad shows nothing in inputs attached to an Input_Calendar RichWidget.  Works fine in Chrome in my Windows desktop environment.

Screen shots show the before and after...

Regards,
GH
Hi Gavin,

The Input_Calendar in 8.0+ behaves differently in mobile and desktop browsers to allow the native datepicker to be used instead (since they are better).

I see that you have multiple datepickers in the page, there was a known issue on that situation that I'm not sure if it is fixed yet.
Can you try with a single datepicker in the page to see if that's the problem?

Regards,
João Rosado
Hi Gavin,

Didn't tried it myself yet, but you may want to try out this component:
https://www.outsystems.com/forge/component/502/pick-a-date/


Thanks Paulo, I did try this one.  Looks good but as Joshua has pointed out in his description it's in development and it has issues at this stage.

Paulo Ramos wrote:
Hi Gavin,

Didn't tried it myself yet, but you may want to try out this component:
https://www.outsystems.com/forge/component/502/pick-a-date/

 
 
 
Thanks João,

I'll try a single control as soon as I can.  I've just come back to my PE after a few hours break over dinner and it's gone haywire.  The new 8.0.1 features are missing e.g. London Theme and layouts - wants to do a reference refresh and remove a bunch of features.  I'm hoping OS are doing some maintenance at it will correct itself?

Cheers,
Gavin
João Rosado wrote:
Hi Gavin,

The Input_Calendar in 8.0+ behaves differently in mobile and desktop browsers to allow the native datepicker to be used instead (since they are better).

I see that you have multiple datepickers in the page, there was a known issue on that situation that I'm not sure if it is fixed yet.
Can you try with a single datepicker in the page to see if that's the problem?

Regards,
João Rosado
 
 
Hi Gavin,

We're not doing anything on the personal environments right now, so something else might be going on. Can you go to your OutSystems home and open the studio from there? 

If you issues continuing happening, shoot a message to success(at)outsystems.com so we can help you out. 

Thanks!