Service Studio Problems on Windows 8.1

Service Studio Problems on Windows 8.1

I've bought a Surface Pro 2 running Windows 8.1.
In the Service Studio (, the area where is Process, Interface, Logic and Data tabsheets is impossible to click on them, so i cant work.
Anyone got the same problem?
I've tried to modify the resolution by increasing or decreasing the size of all items, in the display settings of Windows.

Hello I have the same problem in a Win8.1 laptop.

If I have the SStudio window maximized, when I click that area , the SStudio window is resized to smaller (restored down), if I click again it's maximized, an so on...

Anyone from Outsystems could answer if this is a known bug? Or already fixed?
I think you will get the answer of Windows 8.1 is not currently supported.

So in the time being maybe build a Windows 7 VM and run it in there until the bug you describe is sorted.

Be aware that Windows 8 wasn't fully supported yet. 8.1 is very recent so will have even more known bugs.

Microsoft does not have bugs - just  a lot of undocumented features!!! :)
I have Windows 8.1 on my laptop and I'm having none of these issues.  Might be Surface specific.
It's odd, I recently installed 8.1 on a PC at home, to give it a week or two, and Service Studio runs perfectly on it. My only complaint so far is that Service Studio gives me a 403 (Forbidden) when I try accessing it from IE11, which means I need a copy of Chrome or Firefox just for that.

But yes, IE 11 (on a machine running Service Studio) and Windows 8 are not supported yet.


The problem is with the DPI settings. Even in the Windows 7, if you use a non-standard DPI the problem arises. The Service Studio works without problems in Windows 8 if you have a standard DPI.
To see if you have a standard DPI then go to the Display control panel and see if the percentage is greater than 100%.

The Surface tablet (I have the Surface Pro, the first version) have 125% or more by default so you can read text correctly. That is why the Surface can have full HD resolution in such a small display and you can still read everything.

To work arround the problem, either change the DPI setting in Windows to 100% (not recomended in small displays) or go to the folder where the Service Studio is installed (c:\program files\Outsystems\Service Studio), right click the ServiceStudio.exe, select Properties, Compatibility pane, and check Disable display scaling on high DPI settings.

The Service Studio will work without problems, but everything in it will be a little small... 
By the way, in windows 8.1 you can have different DPI settings per display so if you have a secondary display this could help...

Rui Eugénio
Both solutions work for me.
Many thanks.
Thanks Rui!
Now is working perfectly!
I had the same problem on my Windows 8.1 running on a Laptop (1920x1080) and Rui's suggestion was perfect!
The default instalation applies a 125% DPI. Change it to 100% and everything will be fine.
Changing the display text percentage to 100% works for me, but that won't work in my situation due to the font size being too small (I'm running Win 8.1 in a VMware Fusion 7 VM on my mac). I tried the "Disable display scaling on high DPI settings." but that didn't seem to work. What could I be missing? I followed the instructions as Rui stated. Thanks.
DPI is not the Issue, something is getting out of sync with Service Studio, my UI works for 3-5 right clicks then boom, nothing right clicks or in some cases left clicks either.  A restart of Service Studio solves the issue for few more attempts.  It primarily happens when building entities.  I have a TT in on this....very frustrating as a new user

I actually re-tested. If I try either of the options that Rui mentioned, Service Studio works fine. The problem is that I am running Parallels on a Mac (retina display). So the UI for Service Studio is extremely small.

@Rui- any other suggestions how to make this work?
Hi Josh,

Can you try with the new that was just added as a Release Candidate?

Would like your feedback if it still has issues with High Dpi settings, since it includes fixes for it.

João Rosado
Thanks Rui!!