Image display issue in Firefox and Chrome

Image display issue in Firefox and Chrome

  
Hi Guys, 

 I have an issue regarding on displaying an image in a Webpage. In Internet Explorer (IE8), the image is displayed, 



But when in Google Chrome, there is no image displaying, only the image frame :



it is also the same with firefox, except that even the image frame is not visible.


Firefox : 




when I inspect the element for the image frame, it displays the correct file




and when I click the src part, it displays the image



I am confused why it worked in I.E but not with the more complete browsers Chrome and Firefox. By the way, I am using the "External" Method in uploading the picture. The file is located in this path : //devdb/IMAGESTORAGE/

anybody have faced this type of problem?

Thanks,
Lawrence
Hi Lawrence,

How do you want to show this photo?
it should point to the local file? Usually you have a virtual diretory associeted to the local folder and reference all file using the application server (eg. IIS).

Regards,
Paulo Garrudo
Hi,

Only IE supports local and network shared files in urls. In all others it's considered a security risk and are not allowed.

Like Paulo sugested, you can manually create a virtual directory on your server IIS, target it to your image storage folder and then have the urls use the virtual directory instead.

Regards,
João Rosado
Paulo Garrudo yes it will come from a local file.

Joao ok I will try.



Thank you for your response.

Regards,
Lawrence
 I have already created a Virtual Directory in the Development Server (IIS), how can I access it from the Application? 

 Here is the List for Advanced Settings list :

- Physical Path = C:\IMAGESTORAGE

- Virtual Path = /EIS_Member_Image


Hi,

You should be able to do it using a url link this:
  • http://<servername>/EIS_Member_Image/1057486.jpg
Regards,
Paulo Garrudo
 I have found the answer in this link :

https://www.outsystems.com/forums/discussion/9238/display-image-from-path/

Thank you for answering my inquiry.

Regards,
Lawrence
Hello, I am almost done with my website, but have run into a display error when viewing the image in browsers. When view image with Chrome the menu bar displays a strike-through the menu text instead of underlining it. I have this problem only in Chrome. Any suggestion?

Thank you.
Susanna

Community Manager notice: spammy link removed.
Hi,

First of all, Interesting site :)

Second, I fail to see where the problem is. (Using chrome and don't see any strike-throughs)