Rich Widgets: List_Navigation_GetStartIndex

Rich Widgets: List_Navigation_GetStartIndex

  
Hi, i'm rookie of a rookie at Outsystems. Building mobile application from empty eSpace (from scratch) and got below exception. Kindly help or suggest.Thanks

There was an error processing your request:

 
'List_Navigation_GetStartIndex' Action is incompatible with the 'RichWidgets' eSpace definition. Please update it.
   at sseSpace.RsseSpaceRichWidgets.MssList_Navigation_GetStartIndex(HeContext heContext, String inParamListWidget, Boolean inParamRememberStartIndex, Int32 inParamStartIndexOverride, Int32& outParamStartIndex)
   at sseSpace.Functions.rssespacerichwidgets_ActionList_Navigation_GetStartIndex(HeContext heContext, String inParamListWidget, Boolean inParamRememberStartIndex, Int32 inParamStartIndexOverride)
   at sseSpace.Flows.FlowHomeFlow.ScrnHomePage.

Please click back on your browser and try again or, if the error persists, please restart your session.

'List_Navigation_GetStartIndex' Action is incompatible with the 'RichWidgets' eSpace definition. Please update it'.
Hi Jardel,

It looks like the eSpace you're building has an old reference for the RichWidgets eSpace, you need to refresh it. Open your eSpace in Service Studio and refresh all references. Then publish your eSpace again.
Marco Costa wrote:
Hi Jardel,

It looks like the eSpace you're building has an old reference for the RichWidgets eSpace, you need to refresh it. Open your eSpace in Service Studio and refresh all references. Then publish your eSpace again.
 Hi Marco,
no luck...just followed your suggestion but still same issue.
Anyway thanks.
 

hi Jardel,

what is the version of your Outsystems platform, and what is the version of the RichWidget eSpace? Are they the same? 

Hans
Hi Hans,
outsystems version 8.0.0.15 and rich widgets version 8.0.0.7.
Thanks

Jardel
Hi Jardel, 

you showed the outsystems service studio version. Are you able to see the platform server version? In the servicecenter? Perhaps the richwidget must be upgraded. 
But at first, you can try to republish the latest version of richwidgets in serviceCenter. Than refresh your espace and test it again. If you have the same error, figure out if you can upgrade your richwidget (part of systemcomponents) to the same version as the platform. 
Regards

Hans