Platform on JBoss 7.1.1 Final: Error on Message Queue setup

Platform on JBoss 7.1.1 Final: Error on Message Queue setup

Hi folks,

I'm having trouble with my log service on Platform Server (running under Red Had Enterprise Linux, JBoss Community 7.1.1 Final). It doesn't seem to establish a connection to the database for bulk writing.

Upon further look, I noticed a lot of the following frequent exceptions: javax.jms.JMSException: Failed to create session factory (LogServer.log in attach).

I've also restarted LOGSERVER (...and JBOSS... and all the gang services, too), but no luck. Further troubleshooting didn't tell me nothing else either...

Any idea of what may be causing this or where to look into it further?

   Java RMI port 2033 is also running okay.
   Database connection also seems fine (except for this one and only platform service).
Hi Pedro

Im having the same error:

16:21:19,281 ERROR [outsystems.hubedition.util.ServerLog] (http-/ Error on Message Queue setup: queue/OutSystemsWebServiceLog
Exception: javax.jms.JMSException: Failed to create session factory
16:21:19,281 ERROR [outsystems.hubedition.util.ServerLog] (http-/ Error sending log: javax.jms.IllegalStateException: Unable to create QueueSession because connection not initialized

Did you solved it?

Hi Tiago,

I'm sorry, it's been a long while since I came across this post I don't remember anymore. But indeed very recently I had to troubleshoot a similar error (not exactly this one) related to the JBoss message queue. Anyway I only know I got it fixed by running the configurationtool again (command line /opt/outsystems/platform/, after reviewing the installation checklist. It may help your case increasing the log levels for troubleshooting, and activate the respective OutSystems service log file, by the way.

There's also a specific configuration file for the JBoss Message Queue which I didn't have to mess with.

Hope this helps,