Mandatory Input parameter in screen, problems when not filled.

Mandatory Input parameter in screen, problems when not filled.


I have a screen with table records listing the customers. If you click on a customer to show the details  (a screen called CustomerShow) of the customer you pass the parameter of the customerID in the URL (mandatory input parameter in that screen).

But sometimes when you lose authentication because you stay idle using the application, you have to log-on again and it shows again the CustomerShow screen but with the URL without the parameters, and off course it shows a customer without customerID (just has some elements in the cache).

Can anyone tell me more about this behaviour? What should I do the avoid this situation?

Thank you,


About the behavior
When you lose the session, you lose everything that was in session. The login is built so that it sends you back to the screen where credentials where asked. Apparently not to the url. That can be seen in Login action. I remember adjusting our login in a situation like that two years ago. I can look for it if you need.

How to avoid
In the preparation of the CustomerShow, check if you have Id filled. If not, send back to CustomerList.
Thank you Nuno

But what puzzles me is that the input parameter is mandatory. And it should complain or something about that but it doesn't.

Thank you I will do what you say
Ah by the way Nuno,  if you can tell me how you adjusted the login two years ago would be very nice.

Thanks again