Issues deploying platform server in win 8

Issues deploying platform server in win 8

  
After doin all the config with the configuration tool.on deployment of service center to iis i get this error Error] Error message from node nerd (127.0.0.1): Deployment failed
Deployment failed. Could not invoke ping. Exception: The remote server returned an error: (404) Not Found.
   at System.Net.HttpWebRequest.GetResponse()
   at #sde.#Ode.#Yde.#Rde(String espaceName, String ptaOrTenantName).

same setup works in win 7.Thanks
I've seen this before... is this an upgrade, or have you otherwise manually changed the IIS configuration? When I saw this before, we had a manual app.config setting (around the .woff file extension), and the 8.0.1 upgrade added the same to machine.config (or vice versa). When IIS tried to read the files, it got upset that the same setting was in machine.config AND app.config and wouldn't load the application, so we took it out of app.config, restarted IIS, and it worked fine.

J.Ja
Hi Tmlewin

Did you follow this post on how to configure it on windows 8?
http://www.outsystems.com/forums/discussion/9979/outsystems-platform-community-edition-installation-in-windows-8/

I would say that to get a 404 you probably missed some IIS feature in the configuration.
If you do a IISReset and try again what do you get? Still a 404 or the error changes?

Regards,
João Rosado
@justin @ joao

Thanks but its a fresh install not an upgrade.my iis and every pre-requisite was setup before  i tried the manual install.i use configuration tool  to install platform server.everything goes well but when it comes to deployment of service center ,the error happens.Thanks.
Check the event log for IIS errors.

Try to manually pull that URL.

Turn on IIS tracing and try to manually pull that URL to see exactly where IIS is trying to look for it.

Look at your IIS configuration and make sure that it has Service Center as an "application" and that it points to the right place.

J.Ja
Justin James wrote:
Check the event log for IIS errors.

Try to manually pull that URL.

Turn on IIS tracing and try to manually pull that URL to see exactly where IIS is trying to look for it.

Look at your IIS configuration and make sure that it has Service Center as an "application" and that it points to the right place.

J.Ja
 The Service Center is not there as an application.  Where is the "right place" to point it at?  I tried "C:\Program Files\OutSystems\Platform Server\running\ServiceCenter.336770800" and when I browse to http://localhost/servicecenter/ I get an error message "You are not authorized to view this page".
 
Jacques-Francois -

Re-run the Service Center installation. You can either run scinstall.bat in the Platform Server directory, or do "Apply and Exit" in the configuration tool.

J.Ja
I re-ran it using the scinstall.bat file in an elevated command prompt window.  It seemed to have gone a bit further this time and ended with an error - see attached file for the output.


I also tried again from my computer to connect to the environment, not sure if I am doing it right - by simply entering the server on which I installed the platform's IP as the Environment?  The error I get is attached "Internal network use only - Access Denied."  Could that perhaps be because my local IP is 192.168.1.88 and the server IP is 192.168.253.186 so it thinks that we are not on the same network?
Jacques-Francois -

Never seen that error before. This definitely sounds like a case for the support team, sorry!

J.Ja
Ok, thanks for your inputs!  I will also try the re-run on my local Windows 8.1 PC.