ReST Server Communication

  
Hello Everyone,

I'm trying to develop an integration with a ReSTFull server, where i must go get data through GET Requests.
My problem is, I always get the typical " The underlying connection was closed: Could not establish trust relationship for the SSL/TLS secure channel.  " error when trying to connect...
The server has a valid SSL certificate, and the server firewall connections seems to be right. Any idea what the problem may be?

To connect, I've tried using OS native HTTPRequestHandler, and ardoHTTP component (link below), and both return the same error.

Appreciate any help.

Sincerily, Bruno Alves

ardoHTTP: http://www.outsystems.com/forge/component/427/ardohttp/
(PS: Let me know if this is in the wrong section, was unsure where to post it...)
Stack Overflow has a handy list of potential problems:
http://stackoverflow.com/questions/703272/could-not-establish-trust-relationship-for-ssl-tls-secure-channel-soap

J.Ja
There's also another post on these forums that covers that topic, here.

Basically, what's happening is that you can't establish an SSL connection with the server. This can be for various reasons like:

1) the certificate is signed by a non-trusted authority / self-signed
2) the certificate has expired
3) the certificate was issued to a Common Name different than the address you're using (for example, it was issued to www.outsystems.com and you're accessing the IP directly).

Depending on the case, there are different ways to address the issue. My suggestion is to open a browser in the server machine, access the URL you are trying to get and check what the browser complains about regarding the certificate.