[Animations] Flashing icon on load

[Animations] Flashing icon on load

  
Forge Component
(5)
Published on 10 May by Miguel Ribeiro
5 votes
Published on 10 May by Miguel Ribeiro
Hi Gancarlo

This looks really useful and might just be what I was looking for.  I'm pretty new to Outsystems so may ask some pretty stupid questions, so I apologise now.

I want to use Animate to make a RichWidgets\Icon    Entities.IconName.circle  appear as a flashing red circle ( a warning) upon entering the screen. 

Really not sure how to do this, can you assist?

Many thanks
Andy
Hi Andy,

That's extremelly easy to do.
Just:
  1. add a reference to the blocks on this component,
  2. Drag the AnimateOnScroll webblock to your screen
  3. Drag the icon widget inside the placeholder
  4. Choose the animation from the dropdown - Try flash...
That will get you an icon (style it with CSS as usual) that when the page is loaded (and the element becomes visible) will flash. 



Check the Test example for your scenario.

Let me know if you have any issue.
Thanks Goncalo

I have tried the example you specifiy above, but with no luck I'm afraid.  Tried to show my settings in the attached.

Any help you could offer will be gratefully received.

Thanks
Andy

Hmm.. strange. It looks ok.
Do you see any javascript errors when you access that page at runtime? (check it with the browser inspector). Which browser are you using?
Hi Goncalo.  It was a browser issue (IE8), it looks fine in Chrome/Firefox (just need to play with the actual alignment).

many thanks for your assistance.
Andy