Process not running

Process not running

Hi guys,

I have 2 process that is triggered whenever a record is created on a certain table. I was able to run and execute the process before, I dont know if it has something to do with the data being loaded, since then the process did not work anymore, no active instance runs on the Process Monitoring and no error appeared on the Error Logs, it just halt whenever I debug.

Hi Diana,

It will be difficult to help you troubleshoot without more information. Is the Scheduler Service Running? Is it possible there is an error?

This could be a number of things. Some more information would be useful.
Hi guys,

The process is being launch/ trigger whenever new record is created on a certain table, but whenever that new record is created, the process won't actually run, no active instance is running on Process Monitoring and no error was provided on the error logs.

1) ?What are the processes doing?
2) Is the process launching a console application and/or an extension?

Hi Robert,

Sorry if it took a while for me to response, so here's is the screen captured of the processes

In this two process, TriggerTaskRun is the first process to run


the TriggerTaskRun Process is launch whenever new Record(TaskTrigger) is created:

Inside TriggerTaskRun Process logic, a switch condition is set, if it's  bound to the switch condition (see image below) it will create a BatchProcess record, that will be the launch for TriggerBatchProcessing Process.

My problem now, whenever there's a CreateTaskTrigger, the TriggerTaskRun Process won't actually run thus will not automatically continue with the TriggerBatchProcessing Process since it's trigger/launch will always be dependent on TriggerTaskRun logic. I tried to recreate the TriggerTaskRun process by simply deleting and copying it again, and when tried to run again, the TriggerTaskRun Process actually runs successfully, BUT the problem occurs now on TriggerBatchProcessing Process, even if there's a Created BatchProcess record the process didn't run. When tried to debug, it just stop and no active instance is running on the Process Monitoring inside Service Center, even if I recereated it likewise i did in the first process it still didn't run.

If there is a solution? I have the same situation. Entity is created, but process is not activated. Even if call it manually in action.