[Signature] Clear Signature Button

[Signature] Clear Signature Button

  
Forge Component
(11)
Published on 20 Jun by Magda Pereira
11 votes
Published on 20 Jun by Magda Pereira
I can't seem to get the ClearLink to work.
Tried on google chrome (both desktop and android) and IE.

Am I missing any setting or configuration?
It also doesn't appear to work in Firefox.
It works in the example.  But I still can't get this to work.

Hi folks,


A customer of ours had recently some troubles with this feature, as well. We didn't find this working anywhere, and found out that the issue (in version 1.0.5) is caused by a malformed jQuery element & class selection in Signature.prototype.initUI setup function.

We've made the attached changes in order to get the component working, but please not that it is unlikely that this will allow it to be used multiple times in the same page - since the jQuery selection is not designed for such requirement.


Regards!

Works also on 1.0.4 (Outsystems 9.1).


Thank you for the solution Pedro!


Pedro Gonçalves wrote:

Hi folks,


A customer of ours had recently some troubles with this feature, as well. We didn't find this working anywhere, and found out that the issue (in version 1.0.5) is caused by a malformed jQuery element & class selection in Signature.prototype.initUI setup function.

We've made the attached changes in order to get the component working, but please not that it is unlikely that this will allow it to be used multiple times in the same page - since the jQuery selection is not designed for such requirement.


Regards!



The jSignature widget needs to be placed in the container that will be used for rendering the signature pad, otherwise the clear signature link will not work.

Thank you Ouen Worth.


Ouen Worth wrote:

The jSignature widget needs to be placed in the container that will be used for rendering the signature pad, otherwise the clear signature link will not work.