Cannot publish solutions

Cannot publish solutions

Hi there,
Today I upgraded from to on our local environment. I cannot publish system-components or any solution. Using the Solution Pack Tool, it simply hangs at the first step: "Contacting Service Center to publish Solution Pack", and never stops. Using the Upload Solution Pack in Service Center I choose the file, click upload and it never gets to the upload of the solution, it keeps circling and never stops.
In the General log it says "
12-08-2014 18:19:52 (System) Entity Action CreateOrUpdateSolution_Pack(update) took 1005 ms SLOWSQL

I looked at other suggestions, nothing changes:
The system_components.osp in the platform directory is from 7/31/2014.
I cannot extract system_components or other solutions to publish one-by-one, gives another error.
There is no ongoing solution publish.
The solution system_components in the factory is still at
In the environment health all is idle or sleeping
In IIS, in the application pool for ServiceCenter the Private Memory limit is set to 8882995

Can publisch / upload individual eSpaces, but no solutions.

Help is truly appreciated.

Hello WIlko

The symptom you're describing looks like the request is either getting hanged in the server, or terminated.

To determine if there's any additional error, I would suggest to attempt to upload and publish a solution, and when it doesn't go nowhere, access the Service Center error logs and attempt to identify any additional error. In addition, access the server's Event Viewer System Logs, and check for WAS events, either worker process crashes, hangs, or recycles.

If nothing shows up, check the Worker Processes Requests in IIS (IIS Manager -> Server -> Worker Processes), by selecting the ServiceCenterAppPool and then check if the upload request is still running or not.

Let us know your findings.


Miguel Joao