Combo-boxes will not let me select "Source Identifier Attribute" in V9

I think I found a bug with the new version with combo boxes.  It will not let me select a "Source Identifer Attribute", but it requires one.  Even pre-existing combo-boxes before the upgrade to V9 will not allow me to change it.  This is currently blocking me from using the tool.  Any thoughts?

Hi Jason,

Can you provide a sample?
All you need to do is try to use a structure for a combo box.  It will not allow you to select a "Source Identifier Attribute".  I had a coworker attempt to do the same thing in a different app and he hit the same issue.
I think I see what you're saying. When you select a record list the source identifier attribute is limited to Identifier data types. In release 8 this was not the case. Please submited this feedback via the tool?
Thats probably the case.  I am using structures, which do not contain identifiers... I sent an email to support about this as well.

Had the same problem with combo box.
Still the same bug today. IS FRUSTRATING.
Hi Samuel,

Sorry to hear about your frustration :(
Let me try to help you.... I have a couple of questions first:
  • Can you tell me why you are using structures to fill in the combo box?
  • What is the version of OutSystems Platform you are running?
Finally I'm pretty sure you already did it but it is very important that this feedback reaches our maintenance team so that they can continue to improve the product fixing bugs and wrong behaviors. Do this by using the submit feedback form available under the Help menu.

I despise the mechanic as well.
In v.

1. you cannot select what identifier (which normally is correct, but sometime you want to choose a different one)
2. it's REALLY cumbersome to change it from "Aggregrate" to "Entity" and vice versa.

As you can see, both are greyed out. this means, you cannot alter it in anyway.
first remove it all, then you can chamge it.

Hi J.

Thanks for the feedback!
Can you submit this feedback from the development environment? This way we'll be able to take a deeper look into this case...


This issue has me blocked from finishing my work. So if you would please make this a severe bug item? This field is not enabled no matter what kind of source I try to use. (Source Record List, List, Source Entity).  


Hi James,

Default behaviour for the Combo Box is:

  • if the Source Attribute is an Entity Attribute, then the Source Identifier Attribute will be the Id of that Entity (and you won't be able to assign anything to Source Identifier Attribute.
  • The Source Identifier Attribute will be enabled (and you can choose any Attribute from the list record) if you choose as your Source Attribute a computed attribute from an aggregate (or any attribute that does not belong to an Entity, really)...

Most of the times, this is what people want... but sometimes it isn't and there's still no way around it.

As for the second pain point J. mentioned... it also annoys me tremendously.


It wasn't working with a List object either, so I rolled Outsystems back a version and it works for me. Thanks for the Information Jorge! :-)