[Google Calendar Integration] Critical Google API V2 discontinued

[Google Calendar Integration] Critical Google API V2 discontinued

Forge Component
Published on 2014-09-03 by Isaac Blaise
4 votes
Published on 2014-09-03 by Isaac Blaise
Google discontinued the V2 Google Calendar api on 17 of November of 2014.
All google calendar integrations stoped working.

We do not have an alternative from google because now google api DLL only support framework .net 4.0.

Anyone has a version of this component working on Calendar V3?

Any clue how to solve this quick?
Hi David,

I'll give it a look.
On what version of the platform are you on?

João Rosado
Hi João,

We are using version 8 of the platform
Well, I looked into it.

Not very good news if you are still on Platform 8. Since it will give some work to rewrite it to use full REST requests manually in the extension (because like you said the V3 binaries require .Net 4).

In Platform 9, the upgrade should be easyer since it already allows extensions up to .Net 4.5.1.
(Or even using the API's directly using the REST API support on the platform)

Edit: edited my reply a bit since I was writing it before I seen the previous reply.

João Rosado
We are already rewriting the extension to use full REST requests manually, unfortunately we are not migrating to version 9 soon, so for now we are forced to rewrite the extension.

Thanks for the help