I have this JSON, but I can't seem to turn on the scroll bars for the following chart (sample).  I would only like to show about 10 columns at a time and scroll to see the rest.

scrollbar: {height: 30, enabled:true}


can you post the source?

there are a couple of things I have seen with the highcharts of Outsystems.

- by default they turn things off which you cannot override anymore.
- do you set the scrollbar on "global" level or in the chart itself.


I was using the AdvancedFormat_Init and putting the code in the Highchart JSon input.  I have attached the javascript that is being generated.  Thanks for your help.

Hi all. 

I'm having the same issue. Any news about this?


Any news regarding on this? I have the same issue i am turning the scroll bar to true but it isn't showing. Hope someone helps.


SyntaxEditor Code Snippet

 xAxis: {
        type: 'category',
        title: {
            text: null
        },
        min: 0,
        max: 6,
        scrollbar: {
            enabled: true
        },
        tickLength: 0
    }

Hi All,

the reason scrollbar doesn't work out of the box, is that this needs another library than the ones used by OS.

You can see this in these fiddles, only difference between both is that one of them has

<script src="https://code.highcharts.com/stock/highstock.js"></script>

and the other doesn't.

Fiddle scrolling not working

Fiddle scrolling working


So you could add that extra script into your project to add scrolling capability.  You'd have to find out about licensing, though.

See attached oml for a way of doing it with a webblock.  

Dorine


Edit : This brings with it it's own problems, some styling and integration with OS is missing, (background color of the chart, a title 'chart title' is added automatically,...) so you'll end up having to do some more tweeking if you want to use this.

Solution

I ended up adding to the high charts component to include all the latest versions + javascript files.This way I can copy the examples from their website to generate the charts.  The version included is pretty out of date.

Solution

Hi Thanks for sharing. My simple solution for this problem is, I put it on the container, set style = overflow: scroll; and then I make the width of the graph to 200%.  This helps my problem hope it helps someone too.