error on sql parameters

error on sql parameters

when i will set the sql parameters a error occur.

this is alert: "Invalid Compiler Output"
You need to provide a lot more information in order for anyone to help you.  Ideally, a small OML file with the table(s) you are accessing and the SQL statement that is giving you errors.  If doing that is a problem, at least give us the SQL statement.
this is the sql statement and result. include print screen 

SELECT {Room}.*
FROM {Room}
WHERE @NumberOfAdults > 0
and {Room}.[AdultsCapacity] >= @NumberOfAdults
and {Room}.[AdultsCapacity] + {Room}.[ChildrenCapacity] >= @NumberOfAdults + @NumberOfChildren
and not exists
    (SELECT 1
    FROM {Booking}
    WHERE {Booking}.[RoomId] = {Room}.[Id]
    and (@CheckInDate between {Booking}.[CheckInDate] and {Booking}.[CheckOutDate]-1
        or @CheckOutDate between {Booking}.[CheckInDate]+1 and {Booking}.[CheckOutDate])
    and {Booking}.[StatusId] <> @CanceledStatus)
ORDER BY {Room}.[Price] ASC


The real problem is identified in the warning you are getting indicating a problem with the 'not' portion of the statement.  I would try two things.

1) Wrap the first three WHERE criteria in parenthesis
2) If that doesn't help try the query without the 'and not exists ...' portion and see if it works - I know that's not the result you want but you'll be sure that's where the problem is, or isn't.
the 'not' portion in sql statement not me worry yet.
please see file on down right side: 
when i run the SQL test without define form link to SQL parameters, test is OK.
when the form is set to link the parameters. the test result is wrong
continue... please see file
Hello José Martins

Which is the version of your Service Studio? A collegue of mine, got a similar error, on this particular situation when it upgrades the SStudio from 9.0.3 to 9.0.6. And after contact the support they recognize the problem and said that will be solved in a next version.

I know that not helps you, but at least you keep to know that you are not  the only one with this problem.
i apreciate your effort.
thank you.
i wil continue waiting for next version
Hi José,

As Alberto said, it is indeed the same problem.

Meanwhile, as a workaround you may copy/paste the query to create a duplicate, remove the parameters of the dup and now test query should work on that. You can then delete the duplicate.

Thank u