bin and bin2 folder in IIS is not created

bin and bin2 folder in IIS is not created

  
Hi,

I recently encountered an error during my development in outsystems that doesn't show me the exact error ( "There was an error processing your request. Please try again later..." ) and I got stuck. Then I looked at the IIS and found out that the published espace is not creating a BIN and BIN2 folder in the IIS. What could have cause this issue and how can I fix this?

Thanks,
Ron
Hi Ron,

Can you provide more information? You published the eSpace and nothing happened? Did you have any error during the publication? Can you publish and check both ServicCenter's error log and the event viewer.


Cheers,

Greetings,

"There was an error processing your request. Please try again later..." is the screen that is shown whenever an unhandled exception is thrown. Check Service Center's error logs for the detailed error message. It is very likely that the error is about something much more mundane than the platform missdeploying the application.
Hi jose,

There are no errors on publication and there are no errors logged in the servicecenter. I did notice an error on the event logs but its pertaining to the ECT. Is it related to my issue?

Hi Joao,

how is it misdeployed? I haven't done any change in the configuration on the deployment.

Thanks,
Ron
Hi Ron,

That's weird... did you check the event viewer? 


Cheers,
Hi Jose,

Yes i have checked the event viewer and found a warning which is similar to the error that i have when i tried to access the application in the server.

Please see attached event log waring/error. this is the error on the browser when you access it in the server


Thanks,
Ron
Hello Ron

The bin and bin2 folders aren't crated in IIS, but they should exist in the path C:\Program Files\OutSystems\Platform Server\running\CloneOfERP_SO\

If they are not, then something went really wrong with the deplyment, and you should republish the espace.

If they exists, there's possible some mis-configuration that is affecting the OutSystemsApplications pool. Since you're able to access the ServiceCenter, I assume that ServiceCenter is running on a different application pool (perhaps ServiceCenterAppPool), which is a good configuration option.

Is there any other application you can access on that server, besides the CloneOfERP_SO? I've notice that the pool is configured to run in .NET Framework 4.0, so I assume you're running version 9.0, do you confirm?

Cheers
Hi Miguel,

ah yes, sorry. Bin and Bin2 folders are not created in the IIS, the physical folder are supposed to be created in the said location. and yes they are not created. I've tried republishing the application alot of times now and also tried to rollback from the last working version but the result is the same.

Right now all my application under the platform including the service studio is using the OutsystemsApplication pool. Which is using .net 4.0 and has a classic pipeline mode. Should I seperate the service center under a different application pool? Only this application has an error, all my other applications are working Ok, including the service center.

Yes, there are other applications that are inside the platform, all seems to be working ok, except for this one. yes, its under .net framework 4.0 and yes, its in version 9.0.

Thanks,
Ron
sorry correction, service center
Hi Ron

If the bin and bin2 folders don't exist, then there's something going on with the deployment processes. I would suggest to activate the OSTrace logs for the OutSystsems Deployment Controller and OutSystems Deployment services, change and publish the espace again and collect them and share them for analysis.

You can get information on how to activate these logs at www.outsystems.com/goto/ostrace

Cheers
Hi Miguel,

Tried adding the ostrace in the Deployment Controller and Deployment  service not sure if i had it right. this is what it looks like .

<?xml version="1.0" encoding="utf-8"?>
<configuration>
  <configSections>
    <section name="ServiceSettings" type="System.Configuration.SingleTagSectionHandler" />
  </configSections>
  <system.diagnostics>
    <switches>
            <add name="LogLevel" value="4" />
    </switches>
    <trace autoflush="true">
        <listeners>
            <add name="MyListener"
                type="System.Diagnostics.TextWriterTraceListener"
                initializeData="C:\temp\CompilerService.log"/>
        </listeners>
    </trace>
  </system.diagnostics>
  <ServiceSettings />
  <appSettings>
    <add key="Installation.InstanceName" value="DEFAULT" />
  </appSettings>
  <system.xml.serialization>
    <dateTimeSerialization mode="Local" />
  </system.xml.serialization>
  <startup>
    <supportedRuntime version="v4.0" sku=".NETFramework,Version=v4.5.1" />
  </startup>
</configuration>

The logs doent seem to work. Did I get it right?

Thanks,
Ron
Hi Ron

Have you restarted the services OutSystems Deployment Controller, and OutSystems Depoyment? After changing the respective .exe.config files, you need to restart the services. If the files aren't created, then you should have an error in the event viewer stating why.

Just make sure the folder where you're putting the files exist, and the services can write to it.

Cheers