Detect platform version in extension

Detect platform version in extension

  
With two platforms under maintenance (8 and 9), and some breaking changes with regards to record lists, we have a number of extensions that use different code depending on the platform version. What I'd like is to test for platform version at compile time, so I can use a couple of #if-s to have a single source code base for both platforms. Is this possible?
Hi Kilian,

Currently we don't have a supported way of checking platform version over an extension. The best way to go here is to have separate extensions, one for each OS Platform version.

Cheers!
Nuno Parreira
Bummer! That'll be double work for a while...