Unable to obtain AppInfo

Unable to obtain AppInfo

  
I'm moving the application from one server to another server.

I configured the new server same as the current one. but, still some configuration is missing and getting the below error.

Can you please let me know?

***********************************************************
Unable to obtain AppInfo

Description:
An unhandled exception occurred during the execution of the current web request. Please review the stack trace for more information about the error and where it originated in the code.

Exception Details:
System.InvalidOperationException: Unable to obtain AppInfo

Source Error:
An unhandled exception was generated during the execution of the current web request. Information regarding the origin and location of the exception can be identified using the exception stack trace below.
browsing from inside the server, getting below message.

Could not get host information.
Please make sure the ConfigurationTool has already run. Could not get serial from registry. System.UnauthorizedAccessException: Access to the registry key 'HKEY_LOCAL_MACHINE\Software\OutSystems\Platform Server' is denied. at Microsoft.Win32.RegistryKey.Win32Error(Int32 errorCode, String str) at Microsoft.Win32.RegistryKey.CreateSubKey(String subkey, RegistryKeyPermissionCheck permissionCheck, RegistrySecurity registrySecurity) at OutSystems.HubEdition.RuntimePlatform.Settings.get_MachineSerial() Could not get serial from database. System.NullReferenceException: Object reference not set to an instance of an object. at OutSystems.HubEdition.RuntimePlatform.Settings.GetSerialFromOssysServer() at OutSystems.HubEdition.RuntimePlatform.Settings.get_MachineSerial() at OutSystems.HubEdition.RuntimePlatform.Settings.get_MachineSerial() at OutSystems.HubEdition.RuntimePlatform.DBRuntimePlatform._GetParameterValue(IDbTransaction tran, String parmName) at OutSystems.HubEdition.RuntimePlatform.DBRuntimePlatform.GetParameterValue(IDbTransaction tran, String parmName) at OutSystems.HubEdition.RuntimePlatform.AppInfo.GetParameter(String name) at OutSystems.HubEdition.RuntimePlatform.Settings.Get(String key)Could not get host information. Please make sure the ConfigurationTool has already run. Could not get serial from registry. System.UnauthorizedAccessException: Access to the registry key 'HKEY_LOCAL_MACHINE\Software\OutSystems\Platform Server' is denied. at Microsoft.Win32.RegistryKey.Win32Error(Int32 errorCode, String str) at Microsoft.Win32.RegistryKey.CreateSubKey(String subkey, RegistryKeyPermissionCheck permissionCheck, RegistrySecurity registrySecurity) at OutSystems.HubEdition.RuntimePlatform.Settings.get_MachineSerial() Could not get serial from database. System.NullReferenceException: Object reference not set to an instance of an object. at OutSystems.HubEdition.RuntimePlatform.Settings.GetSerialFromOssysServer() at OutSystems.HubEdition.RuntimePlatform.Settings.get_MachineSerial() at OutSystems.HubEdition.RuntimePlatform.Settings.Get(String key) at OutSystems.HubEdition.RuntimePlatform.AppInfo.get_CacheControlPath() at OutSystems.HubEdition.RuntimePlatform.EspaceProperties.initCache() at OutSystems.HubEdition.RuntimePlatform.EspaceProperties..ctor(AppInfo parentInfo) at OutSystems.HubEdition.RuntimePlatform.AppInfo..ctor(String eSpaceName, Boolean hasRuntimeLimits)

I validated the configuration with my current server and pretty much same one. If any one have some insights on this issue, please let me know.

Hi Jith,

What do you mean by "I'm moving the application from one server to another server."?
From errors it looks like you don't have the platform installed on that machine.

Regards,
João Rosado
How are you moving it to another server?
- Installed the platform on the new server from scratch?
- Is it a new controller server? If so, does it have a valid license key (check under Administration -> License)
- Did you republish all applications / Publish the solution?

Thanks Joao and Goncalo for your replies. I found the reason for the issue. It seems the server name is configured in one fo the table in Outsystems database and required to update the new server name.

dbo.ossys_Server

After update, it works fine now.

Thanks again.

Regards,
Jith