[Turbolinks] Error with reference pages

[Turbolinks] Error with reference pages

  
Forge Component
(8)
Published on 2015-02-05 by Tiago Simões
8 votes
Published on 2015-02-05 by Tiago Simões
Hi ,

I have an issue with the pages that are referenced to the application using this. It seems that the espacename on the URL is being kept that is why when a page that is referenced is being access/redirected to there seems to be an error.

eg:
http://<servername>/<currentapp>/SamplePage.aspx - wrong address

http://<servername>/<referenceapp>/SamplePage.aspx - it should be this one. since it is just referenced inside the app.

It also causes problems with reference widgets that have links/redirect capabilities eg: application switcher.

but all in all,  I find the component really good and can be  very useful. 

Thanks,
Ron
Hi Ron,

Thanks for the feedback.
This is the initial version, as such those and other problems might still need to be ironed out.

If by any chance you can upload an eSpace with the problems you are describing I'll probablly be able to tackle them quicker.

Cheers,
Tiago Simões
Hi Ron,

I was able to reproduce the problem you mentioned, and fixed it so links to other modules now do complete page loads (there is so much thing changing that this is the better approach). The only exception I was not able to tackle is when you have a submit action with a redirect to a different module, but hopefully that pattern is not very common.

The new uploaded versions has also some other improvements:
  • Navigate buttons working better
  • Fixed links to other eSpaces - they now do complete page loads
  • Tested in Java and it works correctly
  • Changed documentation to advise putting this web block before others (e.g in the header)
  • Code documentation

Thanks,
Tiago Simões