Camera not working on iPad

Camera not working on iPad

  
I'm using Outsystems Now on my iPad and iPhone. On my iPhone the camera is working well in my app, but on the iPad I'm only seeing a black screen.

Can anybody help me to fix this issue?
Hello Eric. 

Can you try the sample apps we have available in the demo. You should see a button on the first screen with 'Try our demo'.

If you use the Car Accident Reporting app you'll find a screen where you can test your camera.

Cheers,
Pedro Cardoso
Hi Pedro,

When I try the demo apps it says: No applications found.......etc.

I downloaded the app in my personal environment but, signing in and run the app.....then the following happens......
The Car Accident app isn't working any more. When I hit the next button in the first screen I get a message "Couldn't find any policies!" I already tried to reset the data and bootstrap the data as admin. Nothing works, so I can't try the camera to register the damage. A few days ago this app worked very well, but since the last update of Outsystems Now the app refuses to work.

Any suggestions?
Hello Eric.

I just tested it in my iPad and it worked fine. Can you give some more details of the versions you're using? Both OS Now and iPad version...

Cheers
Pedro Cardoso
Hi Pedro,

iPad 4: IOS 8.1.3, Outsystems Now 1.1.2
iPhone 4: IOS 7.1.2, Outsystems Now 1.1.2

But......I found the problem. I reinstalled OS Now and tried the demo apps. Suddenly the car accident reporting app worked. When taking a picture the app said "has no acces to assets". I looked at the privacy config of the camera and it was checked out. Checked it on, problem gone.

But it's weird that after the update the apps stopped working.


Thank you very much.


That is in fact weird.... Glad you found the problem!