Stuck in Open in Browser

Stuck in Open in Browser

Hey everyone.

I'm doing the online trainning, and I'm on module 4 (Model and Query Data).
I'm doing the trainning application "Orders", and it is stuck in Open in Browser, not allowing me to work on it.
Am I not doing something that I should do?

Hi Hugo,

Are you still having trouble? Can you share your module with us? Use Ctrl+S to export it and attach it on a post here.


Hi André

I'm still having the same problem. I go to my applications in development click in Orders, then select the file to open in the Service Studio. The Service Studio downloads the applications and it goes directly to "Order Details" with the top icon "Open in Browser". I'm not able to work on the application. I really want to continue to practice and do the training.
I'm having problems login out of Service Studio to. I can't seem to be able to click on the icon that looks like a door to log out.

Thanks for your help.
Can you provide some screenshots of what is happening. I opened your module without any trouble.
Hi Hugo,

It goes directly to order Details, cause it was where you made the last change in your aplication. However in the browser it opens in order's screen cause default entry point is to that screen.

When you click "open in browser" it goes to an internal error? it does nothing? .
Try in another screen, make some change and 1click publish and try it to open. If not, send some screenshots of what is happening.

Andrew Tabata 

Here's a screenshot.
The Service Studio doesn't give any error. I try to click on the main flow, for example and it does nothing.
The only thing that I'm able to do is click on the "Open n Browser" icon. I can't go back to the main flow, or go to Data to work on Entities, I can't click on Interface. I try to but it does nothing.

Another thing, I'm not able to log out form The Forge page on Service Studio to. It does nothing also.

Thanks for your help. 
Hi Hugo,

But the screenshot shows the Data tab active...!?!
By the way...if you double click on the Commom header...
it won't go to the Interface and Header webBlock?

I'm running it on Paralles 9 on my macbook pro. Can this be a issue?
All the tabs show but none are active. If I try to double click in any tab, Service Studio will restore (shrink), but nothing happens with my comands.
I've just tried right now to drag something from the rght handside menu to the espace, and Service Studio restored(shrinked). IS it possible that I need to reinstall it again?
I run it on my mackbook air with Fusion without any issue. If this is a parallels issue then you would have troubles using the start menu even, I think. Do you have this issue?
On Service Studio, I'm able to login to my Environment.
But when I choose an application to work on and click on it, like Orders, in the modules screen, where we have also a link to open in browser or manage, I can't click on them, they don't work. Then when I click on application to open it, my eSpace appears, like the attachment I've posted, but all the menus on the right hanside wont work. If I try, for instance, to drag something, Service Studio will restore.

I was looking into the configuration tool, and although I didn't change anything, when I try to close it I've got a message saying that configuration has errors. What can it be?

From the screenshot it looks liek you are using the personal environment. The configuration tool is only need for when you are running the OutSystems Platform on premises, which is not your case. This also means you have installed the Platform Server which you don't need if you are running in the personal environemnt in the cloud.

Regarding your problem with the development environment being stuck I suggest you send an email to

I'm going to reinstall, to see if this solves the problem. If so, I will give feedback.

No success. Sending email for suport.

His Hugo,

That looks like this issue:

Do that and it should fix all your problems.

João Rosado
Hi João

You've saved my life!
In my case, because I'm using Parallels 9, I went to configurations, disabled Retina Preparation. Then on Windows, all I did was Display personalization changed to 100% and that's it!

Thanks again
Hugo Leitão