test query output not same with application output

test query output not same with application output


I have this advanced query that fetched data from different joined tables. I used structured entity for the output, whenever I run the test query the output meets the expected result. However when the whole process runs in the application, the queried result weren't the same with the tested advanced query.

Here's the output from test query:

Here's the result from the application:

Note that there's no inialization used in displaying the records only the advanced query, both used the same parameter.
Without more concrete details it's hard, my best guess is that the runtime variables used in the query don't have the same values that you expect when executing in test mode. It can also be a bug...

Btw there is a difference (and I'm not sure if this has changed so far) between the runtime sql execution and the sql test execution, being that the runtime is a bit more strick, not sure if that could explain it
Are the values different? I can see that until LoanId the result is the same... cannot see more to the right.
Maybe the order of the columns in the screen are just different from the structure order?
Hi Pedro and Tiago,

Thanks for your repsonse. Already tried to upgrade the platform server, that might solve this still got the same output. The Output Structured used here are all Identifiers, which was also used in displaying the values in Record List, same with the advanced query. I actually display the values accordingly.


Notice that from the Test Output Remittance_Batch.PaymentId and Remittance_Batch.PaymentDirect have values.

While the runtime sql execution the values produced '0', other columns showed the right values.

Hi Guys,

Thanks for your response, this is no longer an issue.
Sometimes, all you have to do is talk about the subject, get other insights and you just magically realize what's the solution. ;)