System.Web.HttpUnhandledException when launching a developpement application

System.Web.HttpUnhandledException when launching a developpement application

  
Hello,

I've just finished the '3.2 List Records from the Database' chapter in the 'Developer Online Class',
and i can't get the Home page in the browser when i click the blue button in the Service Studio.


The displayed error message is 'The page cannot be found. Please make sure you typed the URL correctly'

The error logged in the Service Center is :

[1] Exception of type 'System.Web.HttpUnhandledException' was thrown.
   at System.Web.UI.Page.HandleError(Exception e)
   at System.Web.UI.Page.ProcessRequestMain(Boolean includeStagesBeforeAsyncPoint, Boolean includeStagesAfterAsyncPoint)
   at System.Web.UI.Page.ProcessRequest(Boolean includeStagesBeforeAsyncPoint, Boolean includeStagesAfterAsyncPoint)
   at System.Web.UI.Page.ProcessRequest()
   at System.Web.UI.Page.ProcessRequest(HttpContext context)
   at System.Web.HttpApplication.CallHandlerExecutionStep.System.Web.HttpApplication.IExecutionStep.Execute()
   at System.Web.HttpApplication.ExecuteStep(IExecutionStep step, Boolean& completedSynchronously)

[2] Error executing child request for HomePage.aspx.
   at System.Web.HttpServerUtility.Execute(String path, TextWriter writer, Boolean preserveForm)
   at System.Web.HttpServerUtility.Transfer(String path)
   at ssPhoneBook.Flows.FlowMainFlow.EntryHome.Page_Load(Object sender, EventArgs e)
   at System.Web.UI.Control.LoadRecursive()
   at System.Web.UI.Page.ProcessRequestMain(Boolean includeStagesBeforeAsyncPoint, Boolean includeStagesAfterAsyncPoint)

[3] The file '/PhoneBook/HomePage.aspx' does not exist.
 
Do you have any idea ?
Hi Stephane,

It looks like a broken link... where is your entry point going to?
In that screen, on Preparation, do you have a "destination" widget in the end of the action?
Stephane,
You probably have the same problem as another user actually. That second point [2] - Error executing child request is the probable cause.
Follow my instructions on the other discussion:
http://www.outsystems.com/forums/discussion/14477/publishing-my-application/#Post53773 

Hello Tiago,

It seems to be the same problem.

I've published the last version of 'System components' but the problem is not fixed.
When i click on the 'Open in browser', i see the url https://stephanedesvaux.outsystemcloud.com/PhoneBook/ and then it redirects to https://stephanedesvaux.outsystemcloud.com/customHandlers/notFound.aspx?aspxerrorpath=/PhoneBook/Home.aspx

Sorry.
Stephane,
The issues might be different then, the other user did manage to fix it. Is your error log message the same as before or is there any change in the error message now?