Platform 9.0.1.3 - Community Feedback

Platform 9.0.1.3 - Community Feedback

  
Hello everyone,
 
A Release Candidate of the new Platform Server and Development Environment is available: version 9.0.1.3 - download here: http://www.outsystems.com/home/downloadsdetail/88/1376/

Have you tried it? It certainly looks good (new icons) but it also seems to be good!
Some cool new goodies:
  • Expose REST APIs visually
  • OutSystems Now - support for Windows 8.1 and Windows Phone 8.1
  • App Feedback enhancements
  • Starter Templates - create application templates that teams can use as their initial app blueprint
  • Improved IT governance support for app staging and external authentication mechanisms
  • Aggregates evolution - Usability improvements and “Show SQL”
  • Full support for Unicode in development environment
  • Support for Microsoft Azure
  • Support for Microsoft SQL Server 2014
  • Support for Oracle 12c
 
I just wanted to summarize a bit of the new versin and create the stage for sharing these and other issues that you find relevant on the new, still in "Release Candidate" mode, 9.0.1.3.
 
Cheers

Disclaimer: This is a Release Candidate version, made available during its maturation period for the Community's convenience. Unless this version fixes problems that are highly affecting you, it shouldn't be installed in production environments.

PS: I'm not an OutSystems Staff, just an enthusiast!
Here's a screenshot of the new Service Studio 9.0.1.3:


And a list of fixes:
 
  • Support inline base64 images in Email (#382261)
  • Support for data URI scheme on external images (#439002)
  • Fixed error publishing to personal area for the first time, when module contained a custom widget (#706763)
  • Fixed MySQL problem with query readers being closed after commit (#758628)
  • Improved security of Feedback Message first usages (#827087)
  • Fixed Service Center publish button not being visible for users with appropriate security level (#846855)
  • Fixed problem with AJAX request problem when using JQuery 1.4 (#860632)
  • Fixed App Feedback problem on Internet Explorer 8 (IE8) (#862520)
  • Fixed App Feedback problem when retrieving feedback from other environments (#862860)
  • Fixed problem with DBCleaner_API not deleting Process Entities (#870539)
  • Fixed incorrect sort attribute being generated when upgrading simple queries to aggregates (#873585)
  • Fixed problem when creating a details screen for a read only entity (#880990)
  • Fixed Deleting Old eSpace Versions causing broken references to Service Center public elements (#882843)
  • Fixed Service Studio losing focus after Login or after refreshing references (#887007)
We have this information on the downloads page with all the necessary links to the stuff to be aware of...  why replicate it here with multiple posts?

I agree with a discussion on the new stuff, but I think a copy/paste of https://www.outsystems.com/NetworkDocuments/DocumentDetail.aspx?DocumentId=1380&VirtualDirectoryId=91
wasn't necessary...

Sorry...
Hehe that was fast.
We will still put some more information on the following days regarding each of the new features, till it reaches GA.

Ill just take the oportunity to mention that the Expose REST feature requires both Development Environment and Platform Server to be 9.0.1.x
It won't be possible to publish modules with them in older servers.

Regards,
João Rosado
I've already hit the error message, when trying to Expose REST, complaining about the fact that I need Platform Server to be 9.0.1.3 also... Damn ;) Downloaded both now and will test in the coming days
I would also like to ask that anyone that had problems in High Dpi settings before and followed the instructions like these to "fix" it http://www.outsystems.com/forums/discussion/11856/running-service-studio-on-non-standard-dpi-configuration/, to try it again without the workaround and give us some feedback.

If it still looks bad, post some screenshots.