Upgrade to JqueryUI

Upgrade to JqueryUI

  
We have upgraded to Outsystems 9, but we are still running jqueryUI 1.8.24.  How would we go about upgrading to the latest version of the jqueryUI library?
Hi Steve,

The jqueryUI that ships with the Platform is only to be used internally by the Platform System Components.
Previously before Platform 8 it was always available, so if your modules were upgraded and are still set to use jquery Version 1.4.2, then the jqueryUI is still loaded by default in the $ and jQuery instances as backward compability. Also the 1.8.24 is the latest jqueryUI version compatible with jquery 1.4.2.




This is no longer done if jQuery Version is set to 1.8.3.
In that mode you are responsible for providing the version of jQueryUI that you want to use.

I recommend checking the jQueryGoodies component in the forge.
The current version includes jQuery UI v1.10.2, but you can easily upgrade it.

Regards,
João Rosado
Thanks João, that's really helpful.  We have been having a security audit and one of the things it highlighted was the older version of jQueryUI that the platform users.
Well, what I said doesn't quite help on that case then, since internally it will still use the shipped version in the RichWidgets components. So it will still appear on the report.

Can you share what the report complains in terms of security issues? We only use a small part of the jQueryUI (mainly the animations and dialog)
You can send them to me by personal message.

Regards,
João Rosado
I will certainly share the concern when I receive the report which we're expecting to recieve early next week.