outsystem now code 

outsystem now code 

  
hi, i was following the instructions in customising outsystems now source from https://labs.outsystems.net/OutSystemsNowDocs/OutSystemsNowOpenSource.aspx . i completed the modifications as explained nut i get a build error that gradler failed to hook up to its https online repository. i thought the gradle script are bundled with the source code. i was using my android studio offline. do i need to run it online?
Hi,
You should be able to run it online or offline.
Can you share with us a screenshot with that error?
I did some tests offline and I was able to successfully build and run the code.

Cheers,
Luís Silva



more snapshots
@luis here are snapshots  above.Thanks
If you look closely at the code the build .gradle is incomplete ,it doesnt have any applicationid.And the sourcecode is incomplete
Hi,
I guess there is something wrong with your project. How do you imported the code to Android Studio?
There are some missing gradle files on your project. Do you have the build.gradle file for each module or just one file? 
What is the Android SDK version you have installed on your machine?


You project structure should look like this:

yes but i have non of these avilable.the source code i got from outsystems is incomplete.That why i ask , if i have to get gradle by streaming it from their repo
check this snapshot.thats how i imported the code and build.gradle code was incomplete

Hi,
Something is wrong on your environment.
Can you download the latest version of OutSystems' source-code from github and try it again, please?
Just to ensure that you are able to run the latest version without changing anything on it.

Cheers,
Luís Silva


i have downloaded it . and still when i check it some codes are not avilable.please can you kindly attach a sample of the the source code you tested ,let  me try it on my environment and see if i can replicate the issue.Thanks
Hi,
I have been using the latest version available on github and that was the reason I asked you to try it too.
I did some tests in another machine and I was unable to reproduce the issue that you reported.

What is the Android SDK version you have installed on your machine?

Cheers,
Luís Silva

i am using the latest version of android studio. android sdk tool version rev 24.1.2
build tool version 22
Hi,

Please ensure that you have the following packages installed:
Android SDK Platform-tools 21
Android SDK Build-tools 21.1.2
Android SDK Build-tools 20 
Android 4.4W.2 SDK Platform 
Android 4.4.2 SDK Platform