Outsystems directory app issue

Outsystems directory app issue

  
this last snapshots happens when i click the load form with sample data to auto fill the form
more issues .i tried to reload the sample data and i get this error.the location and organization drop down is empty it doesnt retrieve any data from  the database.


the full error description "'CreateNewLocation' Action is incompatible with the 'FloorPlan' eSpace definition. Please update it."
Hi Tmlewin Eruchie.

In order to help you as fast as possible, could you provide us with a bit more information?
Was that a first-install scenario or an upgrade?
What kind of environment are you running the app?
Have you updated missing/broken references?

Thank you.
i have the old directory and google map app. so i upgraded those two components . i downloaded other dependencies like cropper and floor plan independently.then i upgraded my employee services module so as to support new  function lke location etc. lastly i downloaded employee onboarding from forge and installed it. i checked my service center  and there are no warnings or error with regards to dependencies.All references have been updated.its my personal environment.Thanks
Hi again.

My first suggestion would be for you to enter your Service Center, create a Solution and associate your main apps in the components tab.
Please check the 'include dependencies as components' checkbox.
After saving, publish it.
Hopefully this will update any references you might have missed.

Let us know if it helped
i tried publishing all the espaces and dependencies as  an osp solution but still the issues still persist . here is a dropbox link of my osp https://www.dropbox.com/s/7u8qwy49xjborko/employee_directory_v%5BRunning_21_May_2015_18_49_09%5D.osp?dl=0     

i cant attach it here because its more than 20 mb and i figured its too big to upload
Hi.

I installed Directory and Employee Onboarding in a personal environment to see if anything would go wrong, but everything went as expected.
Then, I uploaded and published your solution, but I had to upgrade Employee Onboarding because the 'OnboardingSampleData'  espace was missing.

Please try the following:
Enter you Service Center, look for DirectorySampleData and OnboardingSampleData inside each application.
Set their BootstrapOnPublish Site Property to True and run their 'Bootstrap' timer.
This should load the data.
This was supposed to have happened upon instalation, but something must have gone wrong.

If you have any persisting problems, let us know.

P.S.: Please make sure to have an email setup in your Service Center's Administration area, so the Employee Onboarding data can load properly.
I set the bootsstrap value to true and initiated the timer to load all sample data via bootstrap. And it works like charm .Big thanks for your help

I just have one question although its slightly offtopic, i noticed the app uses the loadzip  to compress and load resources , if i am to import data from multiple excel files via bootstrap, how can i sync changes in content made to the excel file with boostraped data,hence keeping database upto date with changes i made in my excel file,Thanks..