No templates available

No templates available

  
No matter what I do, I cannot create new or use any other templates I install other than London.  They just do not appear in the select theme area when creating an application.  I've followed the steps on multiple websites and your documentation but it does not work.  I'm not sure if I'm missing something.  I have 9.0.1.5 so I should be able to easily make and use templates.  I uploaded a screenshot of nothing but london.
So I figured this out if anyone else is having the issue. Our cloud servers are not upgraded to 9.0.1 yet.
I am having this issue too. What should i do @Thomas? Should I upgrade outsystem to 9.0.1
You said you upgraded to 9.0.1.5, you mean the Service Studio right? What about the server?

Best regards,
PC
So I upgraded Service Studio to 9.0.1.5 and was still having the issue, went through documentation, over and over, and finally realized after reading something and investigating our cloud environment that our server is still at 9.0.0.38.  We submitted a ticket to upgrade to 9.0.1 so we can use templates.  Templates are a must for our organization and right now we are at a standstill until it gets upgraded :(  

Tama, 
You need to upgrade your Service Studio (the IDE you program in) and the actual Server to 9.0.1.  Both have to be upgraded to 9.0.1 for it to work.  It looks like most of the hosted environments are not at 9.0.1, which seems weird/annoying that they would put out a new IDE version, tell you in videos/documentations, etc. that you can do lots of cool things like templates and then not automatically just upgrade the server environments.  If anyone from outsystems is reading this, I think you should post/sticky/put out something that says this is an issue that both server and service studio have to be 9.0.1 to do templates. It is really hard to find both of those pieces of information.

Our server is currently at Version 9.0.0.23
Thomas, they had this post about a month ago explaining how to get the upgraded version of the PE.

Usually when there is a version change like Amsterdam, the servers will not be automatically updated to the new version. Usually the IDE isn't even compatible between versions (I remember having both 8.0.0.X and 8.0.1.X installed in my machine due to that)

Best regards,
PC
We actually have the Enterprise hosted version of the PE and no one told us that this was even an issue or could be an issue.  I did read that 9.0.1 is actually backwards compatible with the other 9.0's.  I can't find any information on how to really get our servers upgraded, we emailed and submitted a ticket but haven't heard back. With are in the US, do you have any experience with actually calling support?
Update to this.  I called customer support and opened a ticket to have our server updated. They were able to schedule it the beginning of next week. They were actually really great on the phone (which is hard to find with a lot of companies).  So cudos to Outsystems.  So if anyone else is running into this issue, just give support a call or if it is a personal environment there is documentation on how to request an update.




Thomas Burdick wrote:
No matter what I do, I cannot create new or use any other templates I install other than London.  They just do not appear in the select theme area when creating an application.  I've followed the steps on multiple websites and your documentation but it does not work.  I'm not sure if I'm missing something.  I have 9.0.1.5 so I should be able to easily make and use templates.  I uploaded a screenshot of nothing but london.