I'm trying to send an authenticated mail using Richmail extension, but I got an error at RichMailSend action.
The error is this:

A connection attempt failed because the connected party did not properly respond after a period of time, or established connection failed because connected host has failed to respond    at System.Net.Sockets.TcpClient.Connect(String hostname, Int32 port)
   at OutSystems.NssRichMail.SMTPMail.SendMail()   
     at ssTesteEnvioEmailGoflo.RssExtensionRichMail.MssRichMailSend(HeContext heContext, String inParamServer, String inParamMail, String inParamIdentity, String& outParamMailId)
   at ssTesteEnvioEmailGoflo.Actions.ActionRichMailSend(HeContext heContext, String inParamServer, String inParamMail, String inParamIdentity, String& outParamMailId)
   at ssTesteEnvioEmailGoflo.Flows.FlowMainFlow.ScrnHomePage.Preparation(HeContext heContext)
   at ssTesteEnvioEmailGoflo.Flows.FlowMainFlow.ScrnHomePage.Page_Load(Object sender, EventArgs e)
   at System.Web.UI.Control.OnLoad(EventArgs e)
   at System.Web.UI.Control.LoadRecursive()
   at System.Web.UI.Page.ProcessRequestMain(Boolean includeStagesBeforeAsyncPoint, Boolean includeStagesAfterAsyncPoint)
eSpaceVer: 39 (Id=41376, PubId=48792, CompiledWith=
RequestUrl: http://siscanosdes/TesteEnvioEmailGoflo/Home.aspx?_ts=635678186043618416 (Method: GET)
AppDomain: /LM/W3SVC/1/ROOT/TesteEnvioEmailGoflo-53-130767061966746091
FilePath: C:\...\PS\running\TesteEnvioEmailGoflo.649987815\HomePage.aspx
Locale: en-US
DateFormat: dd/MM/yyyy
PID: 9364 ('w3wp', Started='21/05/2015 17:29:24', Priv=444Mb, Virt=5787Mb)
TID: 26
Thread Name: 
.NET: 2.0.50727.5485

I think that I need to inform the port I want to connect, but where I inform it?

As far as I know, there's no way to specify the port. RichMail assumes it's the standard SMTP port, which is 25 or 587 for non-encrypted connections (I assume RichMail tries both, but I'm not sure). But assuming that UOL uses standard ports, there must be something else wrong. Can you e.g. ping the server or telnet to it from the server your software runs on?
Did you checked the server configuration? You can change the email settings here:

Best regards,
Pedro, are those settings used for RichMail too? I thought they only applied to the platform e-mail functionality.
You are correct, I was thinking he was sending directly with the plataform Send Email.

I've not use the extension in a while, did you try " <port>" or "<port>" 

Dont remember also if this is a possible option for port, I'm checking if I can find some old eSpace with RichMail send

Best regards,
No luck finding a sample using different ports then the default 25 :(

Best regards,

Pedro Coelho's Solution above "<port>" works!

I had the exact same error as the original poster, which I was able to fix by specifying the port in the RichMailSend action by adding ":<Port>" to the end of the Server input parameter.

Kind Regards