Consume SOAP


I'm trying to consume a SOAP webservice that falls into "Unsupported". For that, I made an extension in Java that consumes the SOAP method and exposes an action to use in Service Studio. After all those compile problems left behind :) the code works (I hope so). But when I run de app, I get an error (see attachment).

What do I have to pay attention at?
Does the OutSystems server has to have explicit access to the server where is the WebService?

Hi Mário,

What do you mean by "Does the OutSystems server has to have explicit access to the server where is the WebService", especially with "explicit access"?
Hello Kilian,

By "explicit access" I mean, for instance, do I have to add a rule (iptables) to allow communication between the two servers, or do I have to change any folder permissons on jBoss subfolders.... I don't know...

Hi Mário,

It's still not clear to me. Your extension consuming the webservice is running on the OutSystems server. So how could that extension communicate with the webservice (i.e. with the remote server) if it doesn't have access to it (i.e. it can't reach it via TCP/IP)?
Hi Kilian,

In fact, the OutSystems server can communicate with the other server, that contains the web service (lets call them and The problem, I supose, is when the extension tries to find and can't find the class WebServiceLocator.
If you take a look at the png file attached, you can see the resource servicedesk.webservice that I created to consume the SOAP ws and then an Action (OS_EZV_CreateRequest) will consume the method I want. Is that new resource missplaced?


Unfortunately, I have no Java-specific platform knowledge, so I can't answer that. If I were to guess, it would seem to me that either there's some external library or the like not found, or you forgot to include something in the extension.
Thanks for trying to help.

I'm afraid of not follow the right steps to create an extension from the scratch...

Again, thanks

Hi Mário,

What instructions did you follow to create your extension?
I ask because from the screenshots I can see it using axis libraries and that is not the recommended way (unless it falls into rpc-literal webreferences that really needs to be axis)

There is this thread post from Leonardo Fernandes that explains how to consume the web reference using jax-ws (a more modern library than axis).
If you really need axis, then if you scrooll on the thread a bit more you will find my post with the instructions for axis as well.

João Rosado
Hi João,

Thanks I'll see if it works for me. I also found this post, but the one you suggested seems more up to date.

I'll be in touch...