Outsystems Now Android App


We've got a fully working 9 platform available with several Android devices accessing through Outsystem Now app.

Recently we acquired a Huawei P8lite device with Android 5.0 and even though the app was installed successfully and accesses our plataform correctly, the list of available applications doesn't render on screen, showing only a blank page (with the "< Logout", see screen attached). Curious though that if we click on the area where the application icons should be, the application opens and is fully working. Seems to be a render issue.

We've already reset the device and started all over with the same results and surely the issue doesn't show up on other devices.

Would it be a screen size issue (5'')? Any ideas?
Hi Bruno,

I don't think it would be a screen size. Android 5.0 is supported... Some device specific issue?

By the way, are there any errors log?
I've been looking for errors and found out that after clearing the app data, on the "OutsystemsNowService" eSpace an error is logged with the message "Cannot insert duplicate key row in object 'dbo.OSUSR_3CN_DEVICE' with unique index 'OSIDX_OSUSR_3CN_DEVICE_10HARDWAREID'. The duplicate key value is ().
The statement has been terminated."
Any thoughts?
Well, my thoughts are this is a bug in the OutSystemsNowService :). It seems the OutSystemsNowService wants to insert something in its Device entity, resulting in a duplicate key violation. Why it wants to insert an empty value I don't know, but there must be an empty value already in the table (for attribute HardwareId, which despite its name is not an Identifier/foreign key but a text string).

Which version are you using? Maybe some backwards compatibility issue?
The concept of hardware id was introduced with 1.1.0 to allow a user to be logged in with multiple devices at the same time.  That version and above aren't backwards compatible, so you really need to update OutSystems Now modules. May that be the origin?
Hi again,

Thank you for your interest!

We were using version 1.1.5. Following your valuable hints, we're now working with the latest (1.1.11).

Still not working, same issues. The only thing that I noticed is that there is no error message logged anymore.

Meanwhile, to clear the chances of being something with the way that the device was registered on the database, I deleted all the records on the OSUSR_xxx_DEVICE, clearing all "User Device logs" on the Outsystem Now Service eSpace. It had several rows with null on the PUSHTOKEN column.

Still not working. Checked that now the device is correctly registered on the database, with valid Push Token.

I'd appreciate any more ideas!
The end result is that the screen still doesn't render correctly and you just get a blank page?

Although, now you get no error message in log and harware id is correct with valid Push Token... My ideas are running out. Anyone else have faced a similar issue?
Hi Bruno,

Just to be clearer, what issues are you facing now?
If you go to the first screen of the OutSystems Now app and choose the "Try Our Demo" option, can you see the demo apps available? Or you got the same blank screen with the "Back" button?


On the "Try Our Demo" everything seems to be working. The issue appears when connecting to any of our environments (development, q&a and production) and only on this device. We have several other devices with no issues. This is an Huawei P8lite, Android 5.0, 5'' screen.

To be clear, I am able to log on the environment but on the page where the apps would display, there is only a blank page as the screenshot shows. Further more, all the apps seem to be there. As we click on the area where the icon should be, the underlying app opens and is fully working.

Any ideas, anyone? Thank you!
Hi Bruno,

Can you tell me please, what is the version of OutSystems Now app that you have installed on your device?

Bruno already wrote that, at first 1.1.5, then 1.1.11.
Hi Luís,

We are using the latest available on the Play Store. 1.1.4, updated on 27/04/2015, at the present itme.
Hi Kilian,

The latest version of OutSystems Now app for Android is 1.1.4.
So, I guess the versions mentioned by Bruno were related to the OutSystems Now component available on forge, where the latest version is 1.1.11.
Right, I must've mixed that up, appologies.
Hi Bruno

I've been running a few tests using devices and emulators with Android 5.0.2 and 5.1.0, and I wasn't able to reproduce the reported issue.
Can we reach your dev environment? If yes, you can PM me the credentials and we can check here if we can reproduce and solve this issue.

Luís Silva


If you guys get this issue sorted out, please give us some feedback for future reference.

Even though everyone’s best efforts, we were unable to solve this issue. Seems like some feature on this device messes with the app. Every environment it reaches (except the “Try Our Demo”) has the same render issue.
Will give up as everything seems to be working fine with every other devices we’ve tried.
For future record, the last tests were made with the OutSystems 1.1.5 Android app and with the OutSystems Now 1.1.13 version on the Forge. The device is an Huawei P8lite (ALE-L21), Android 5.0, 5’’ screen.
Thanks Luís for the help provided!

Thank you for the feedback Bruno.

@Luís Silva - Is OutSystems aware of some other devices out there with similar issues?
Hi Tiago,

Sorry for the late reply.
This was the first "unsupported device" issue that was reported to us. At this moment we are not aware of other devices with similar issues, but we're working on it. 
We'll let you know if there is any new developments.

Luís Silva