[Advanced Excel] Version 9 - CellWriteByIndex and Cell_WriteByName error

[Advanced Excel] Version 9 - CellWriteByIndex and Cell_WriteByName error

Forge Component
Published on 2015-10-06 by Carlos Freitas
19 votes
Published on 2015-10-06 by Carlos Freitas
Having implemented the update to the extension as listed below:


,I now receive the following error when trying to write to a cell using the writebyname function:

"Specified argument was out of the range of valid values.
Parameter name: Address is invalid or out of range"

If i switch to writebyIndex it doesnt seem to do anything at all.

This was working 100% BEFORE i upgraded to V9 and upgraded the component. 

Has anybody experienced this?


Hi Tom,

have you already solved this problem? if yes, what have you done? 

Thanks in advance,

Pedro Ascensão
Hi thanks for the response.

No we havent managed to find a solution yet, without analysing the extension in integration studio.
Shame, as we had built a lot of functionality around this and i guess if we cannot fix it we will need to redesign the application and use a different excel extension if a fix isnt identified.

Have you had a similar issue?



yes, we have the same issue.

We are analyzing the extension.

When it's fixed, we will inform you.



We had the same issue with this extension, and with the help of debugging, found out that the problem was the EPPlus dll used.
We downloaded the EPPlus 4.0.4 from http://epplus.codeplex.com/ and replaced the dll and xml on the Excel_Package extension, rebuild solution, published the extension and refreshed the consuming eSpace's.
I hope this works out with your problem as well.
Best Regards

Brilliant thanks, well discovered!

Are you be able to upload the re-published extension in this discussion?
If not i will follow the steps you have suggested and let you know.

Thanks again.


Hi Tom,
Unfortunately I can't do that, since our extension have some code we implemented that is private, but I think with the steps you can make the extension work again.
Best Regards

I am still having difficulties.

I have replaced the EPPlus.dll in visual studio and rebuilt the solution. I thencopied the new EPPlus.xml file into the bin folder of the project and then verified and published the extension in integration studio, updated the references and republished the epsace.

Im still getting the following error: "Specified argument was out of the range of valid values. Parameter name: Address is invalid or out of range"

Im not sure if i have followed your steps correctly?

Would appreciate a bit of help!

I've attached the extension that we have been using since we migrated to 9.

It has an updated EPPlus library version 4.0.4. The main change is that we are not able to use the Workbook_Open function any more. Currently to open a template use the Workbook_Open_Binary passing a file that is in the resources like "Resources.[Excel_File.xlsx]".

Please let me know if this worked.

I have uploaded the new extension and updated the references and have republished the epsace.
Still getting an error on the Cell_WriteByName action. I have included screens below:


To understand the problem, I suggest instead of using WriteByName can you try WriteByIndex. If that does not work, try a blank template and the WriteByIndex function.

I have tested with the WriteByIndex functio and that works fine.
I have updated all of our methods to use this instead.

Not sure what the issue is - maybe some sort of parsing probem from "B4" to (4,2)?

Anyway - thanks for your help and Joel too above.

I cant seem to use any other data type other than text, if I use decimal or integer or date I get different exceptions thrown every time I was using cell_writebyname but that get failing since upgrading to version 9, I change it to cell_writebyindex and that has resolved the writing issue but now I am unable to format the data type of the cell.
I have changed the version of the extension to Excel_Package_2_v10.xif

I have change the way that we open and load our tamplates and write to them now using cell_writeByIndex.

the file that is finally generated seems to have an excel error in it and everytime I open the newley created template it tells me I have to repair it.

this is a big problem for my team at the moment as it is holding us back from upgrading to outsystems 9.0 and it is preventing us from going live with a new project.

any help would be appreciated

this was all working in outsystems
I have now resolved this issue and I have uploaded a new version of the extension