[Silk UI Framework] cannot publish/upgrade SilkUI to 1.1.0

[Silk UI Framework] cannot publish/upgrade SilkUI to 1.1.0

  
Forge Component
(45)
Published on 10 May by OutSystems Labs
45 votes
Published on 10 May by OutSystems Labs
I get the following errors (via service center, via service studio I get ziclh information, just it won't publish 1 component). We have 9.0.1.4 on our server.
Required Permission You are not allowed to use the Entity 'Espace_Version'.
Required Permission You are not allowed to use the Entity 'Espace_Reference'.
Required Permission You are not allowed to use the Entity 'Espace'.

Hello Joost,

This happens because this new version of SilkUI uses those 3 entities, which are System entities. 

Looking at the documentation, you need to have "change and deploy permissions in the default role to create these references".

Can you please check if you have those permissions?

Best regards,
Samuel Jesus
I believe I have those (I have published, deployed, created new apps,espaces)


Hello Joost,

Sorry for the late reply.
It is really weird, since the previous versions of SilkUI already had one System entity referenced, and as far as I know you are already using those versions, so I think you should be ok to publish it.

I talked with OutSystems support and apparently this may be a platform issue that was solved on one of the latest versions of the platform, and you probably still don't have that version. In order to get more information, I would suggest that you contact OutSystems Support so that they can help you with this issue.

Best Regards,
Samuel Jesus



Hi Guys,

We are having the same problem, our server runs in Development Mode version 9.0.0.19 and my service studio is version 9.0.1.55, we also have the permissions needed for developers, any advice? Thanks.

Hello iSh, 

This issue as far aswe know is not Silk UI related, so I suggest that you contact OutSystems support so that they can help you with it.

Best Regards,
Samuel Jesus
Samuel Jesus wrote:
Hello Joost,

This happens because this new version of SilkUI uses those 3 entities, which are System entities. 

Looking at the documentation, you need to have "change and deploy permissions in the default role to create these references".

Can you please check if you have those permissions?

Best regards,
Samuel Jesus
 
 
Hi Guys,

We resorted on downloading the lower version referencing on the version of our platform, we're good to go. Thanks.
Hello Israr,

I'm not sure what you are trying to share with us, but you shared a webpage.

Thanks,
Samuel Jesus
Hello iSh,

I'm not sure which version of Silk UI you installed, but ideally you should install the latest version of Silk UI. Every new release brings neew features, but also fixes to bugs. By using an older version, you may have bugs that were already solved.

Again, let me I suggest that you contact OutSystems support. They will help you understand what is happening with the permissions, and then you will be able to use the latest version without any issues.

Best Regards,
Samuel Jesus




iSh wrote:
Hi Guys,

We resorted on downloading the lower version referencing on the version of our platform, we're good to go. Thanks.
 
 
Hi Samuel,

As much as I wanted to install the latest version our server cannot publish it due to version difference, we'll do so as soon as we upgraded our servers' platform. Thanks.
Hello iSh,

When we launch a new version of Silk UI we always launch 2 versions: a version for Bali servers (9.1) and a version for Amsterdam servers (9.0.1).
So, although the latest version (2.2.0) is for Bali you can install version 1.4.0, which should be compatible with your server.

Cheers,
Samuel Jesus