[Oracle Connector P9] Functions are not working

[Oracle Connector P9] Functions are not working

Forge Component
Published on 2015-03-13 by Grazina
8 votes
Published on 2015-03-13 by Grazina
I've using Oracle connector extension in our enviroment for a long time in version 8 of the plataform, in fact this connector is one of the most important one for us, it is used for example for register orders in our ERP.
But now since we started the upgrade to V9, calling functions is not working with this component.
For debuging created a simple funcion on my oracle DB that recieves 3 parameters type text, and inserts a record on the DB and returns the second parameter.

CREATE OR REPLACE function f_teste_out
(texto in varchar2,texto2 in varchar,texto3 in varchar) return varchar2 is
    insert into table_name ("A","B","C","D") values (texto,texto2,texto3,'entrou');
    RETURN texto2;

When this function is called by this connector the first parameter is lost and nothing is returned.

I kindly ask outsystems programmers or someone to fix this connector since I rely core functionalities on it.

Order parameters were changed.

This should be fixed in version 0.1.3 can you give it a test drive to see if it's working for you?

Thank you

I tried the call again with version 0.1.4 and haven't succeeded.

"CREATE OR REPLACE function f_teste_out3 (texto in number,texto2 in number) return  number is
    RETURN texto2;

Also tried the above function.

I'm getting "Connector unsupported type : STOutputStructure"

Can you simulate the same call on your side?

I have just release version 1.0.0 which makes the semantics for return value much clearer (they are now separated from the simpleouts).

Beware: this version introduces breaking changes, regarding the return value for functions but also with Null values in parameters