Installation blocking error: Configuration Tool encountered an error

Installation blocking error: Configuration Tool encountered an error

  
I am attempting to create a new install of a farm deployment on AWS, and received an error at the point of first running the configuration tool.

I have googled and searched this forum and sorry if the answer is out there, I can't seem to find it.  Any help is greatly appreciated.

I am following this installation guide: http://www.outsystems.com/home/document-download/1183/88/0/0 - Doing everything as root
  • Setting: First Install
  • Setting: Deployment Controler Server + Frontend Server + Database
  • Setting: Farm
  • Setting: JBoss AS 7.1.1 Final
  • Setting: Linux CentOS 6.X - 64 bit
  • Setting: MySQL Database on Amazon RDS
  • Followed all the steps successfully up until: Configure OutSystems Platform
REPATABLE ISSUE
Output upon executing: /opt/outsystems/platform/configurationtool.sh
  1. Initializing...
  2. Registering JCE libraries in /etc/alternatives/java_sdk_1.6.0/jre/lib/security/
  3. TERMS OF USE (agreed to)
  4. Increasing the maximum open files of jboss to 65535
  5. Starting jboss-outsystems-mq:                              [  OK  ]
  6. Starting jboss-outsystems:                                 [  OK  ]
  7. An error has ocurred:Configuration Tool encountered an error while creating the settings key file.
Error is repeatable (additional attempts render 5 & 6 as jboss already running, and 2, 3, and 4 not shown).

Error Log (/opt/outsystems/platform/logs/ConfigurationTool.log): http://pastebin.com/NS5DkqjJ

Error Source Line traced to /opt/outsystems/platform/configurationtool.sh:
runCommandAsUser "outsystems" "$COMMON_ENV_VARS $CONNECTOR_ENV_VARS $JAVA_HOME/bin/java $JAVA_OPTS -classpath $CLASSPATH outsystems.hubedition.configurationtool.ConfigurationTool $ARGS"

My topology is:
Database:
  • AWS.RDS Aurora DB Cluster (applied the mysql create scripts successfully with modified passwords)
  • db.r3.large
  • (I know this isn't officially supported)
Frontend:
  • AWS.AMI Centos.org
  • 2.6.32-431.el6.x86_64
  • 3 devices mounted:
  • 8GB --> /
  • 80GB --> /opt/jboss-as-7.1.1.Final/standalone
  • 80GB --> /opt/outsystems/platform  version.txt: 9.0.1.25 (build 53665: tags/v9_0_1_25 @ 2015-08-11 21:00:00)
Deployment Server:
  • AWS.AMI Centos.org
  • 2.6.32-431.el6.x86_64
  • 3 devices mounted:
  • 8GB --> /
  • 80GB --> /opt/jboss-as-7.1.1.Final/standalone
  • 80GB --> /opt/outsystems/platform  version.txt: 9.0.1.25 (build 53665: tags/v9_0_1_25 @ 2015-08-11 21:00:00)
When you run Configuration Tool, are you always getting the following message shown:

  1. Registering JCE libraries in /etc/alternatives/java_sdk_1.6.0/jre/lib/security/
If so, there may be an issue with your java installation, somehow.
I just noticed your mention that that specific message is not shown on subsequent runs of Configuration Tool.

The pastebin you posted is the full contents of the ConfigurationTool.log file?
So, the most likely reason for this to be failing would be if the outsystems user cannot create files in the /opt/outsystems/platform directory.

It seems that you have created a partition for /opt/outsystems/platform . Can you show us the result of the following command?

ls -lhd /opt/outsystems/platform


Thanks Ricardo, I've destroyed the instances and moved on, but mainly because the community version seems to be stopped as of 8.

Cheers